Bug 994470 - Error in PREUN scriptlet in rpm package kde-settings-kdm-19-23.fc19.noarch
Error in PREUN scriptlet in rpm package kde-settings-kdm-19-23.fc19.noarch
Status: CLOSED DUPLICATE of bug 989145
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 07:01 EDT by Garry T. Williams
Modified: 2013-08-09 19:56 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 17:35:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garry T. Williams 2013-08-07 07:01:00 EDT
Description of problem:
yum update of kde-settings-kdm fails with:

  Cleanup    : gstreamer1-plugins-good-1.0.8-1.fc19.x86_64                31/50
  Cleanup    : kde-settings-19-23.fc19.noarch                             32/50
  Cleanup    : qt-settings-19-23.fc19.noarch                              33/50
/var/tmp/rpm-tmp.E7drRt: line 1: fg: no job control
error: %preun(kde-settings-kdm-19-23.fc19.noarch) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package kde-settings-kdm-19-23.fc19.noarch
error: kde-settings-kdm-19-23.fc19.noarch: erase failed
...
Failed:
  kde-settings-kdm.noarch 0:19-23.fc19

Complete!


Version-Release number of selected component (if applicable):


How reproducible: Don't know except to do yum update.


Steps to Reproduce:
1. yum update
2.
3.

Actual results:
Failure as above

Expected results:
No failure.

Additional info:
$ rpm -qa|grep kde
kde-workspace-4.10.5-3.fc19.x86_64
kdelibs3-3.5.10-53.fc19.x86_64
kde-baseapps-libs-4.10.5-1.fc19.x86_64
kdenetwork-krfb-4.10.5-3.fc19.x86_64
kdeplasma-addons-libs-4.10.5-1.fc19.x86_64
kdegraphics-strigi-analyzer-4.10.5-1.fc19.x86_64
kde-plasma-yawp-0.4.5-1.fc19.x86_64
kde-plasma-networkmanagement-libs-0.9.0.9-1.fc19.x86_64
polkit-kde-0.99.1-1.20130311git.fc19.x86_64
kdepimlibs-akonadi-4.10.5-1.fc19.x86_64
kdegames-minimal-4.10.5-1.fc19.noarch
kdenetwork-kget-4.10.5-3.fc19.x86_64
kdepim-libs-4.10.5-1.fc19.x86_64
pykde4-4.10.5-1.fc19.x86_64
kdenetwork-krfb-libs-4.10.5-3.fc19.x86_64
kde-runtime-drkonqi-4.10.5-1.fc19.x86_64
kde-settings-kdm-19-23.fc19.noarch
kde-settings-ksplash-19-23.1.fc19.noarch
kde-workspace-libs-4.10.5-3.fc19.x86_64
kdelibs-4.10.5-1.fc19.x86_64
kde-runtime-4.10.5-1.fc19.x86_64
kde-plasma-networkmanagement-pptp-0.9.0.9-1.fc19.x86_64
spherical-cow-backgrounds-kde-18.0.0-2.fc19.noarch
kde-plasma-networkmanagement-0.9.0.9-1.fc19.x86_64
kde-plasma-networkmanagement-openvpn-0.9.0.9-1.fc19.x86_64
kde-settings-plasma-19-23.1.fc19.noarch
kdelibs-common-4.10.5-1.fc19.x86_64
kdenetwork-krdc-4.10.5-3.fc19.x86_64
kde-runtime-flags-4.10.5-1.fc19.noarch
kdepim-4.10.5-1.fc19.x86_64
kdenetwork-kdnssd-4.10.5-3.fc19.x86_64
kdeaccessibility-4.10.5-1.fc19.noarch
xsettings-kde-0.12.3-5.fc19.x86_64
kdepimlibs-4.10.5-1.fc19.x86_64
kdenetwork-common-4.10.5-3.fc19.noarch
kdenetwork-kget-libs-4.10.5-3.fc19.x86_64
kdepim-runtime-libs-4.10.5-1.fc19.x86_64
kde-baseapps-4.10.5-1.fc19.x86_64
kde-print-manager-4.10.5-1.fc19.x86_64
schroedinger-cat-kde-theme-18.91.5-1.fc19.noarch
kde-filesystem-4-45.fc19.x86_64
spherical-cow-kde-theme-18.0.2-1.fc19.noarch
libkdegames-4.10.5-1.fc19.x86_64
kdepimlibs-kxmlrpcclient-4.10.5-1.fc19.x86_64
kdepim-runtime-4.10.5-1.fc19.x86_64
kdeartwork-kxs-4.10.5-1.fc19.x86_64
kdeartwork-screensavers-4.10.5-1.fc19.x86_64
kdegames-4.10.5-1.fc19.noarch
kde-settings-19-23.1.fc19.noarch
lockdev-1.0.4-0.7.20111007git.fc19.x86_64
kde-plasma-networkmanagement-openconnect-0.9.0.9-1.fc19.x86_64
kde-settings-kdm-19-23.1.fc19.noarch
schroedinger-cat-backgrounds-kde-18.91.0-1.fc19.noarch
kdeplasma-addons-4.10.5-1.fc19.x86_64
libreoffice-kde-4.1.0.4-5.fc19.x86_64
kde-plasma-networkmanagement-vpnc-0.9.0.9-1.fc19.x86_64
kde-settings-pulseaudio-19-23.1.fc19.noarch
kdenetwork-krdc-libs-4.10.5-3.fc19.x86_64
kde-runtime-libs-4.10.5-1.fc19.x86_64
kdegraphics-thumbnailers-4.10.5-1.fc19.x86_64
Comment 1 Tom Horsley 2013-08-07 07:31:30 EDT
Me too. And I notice that rpm -q kde-settings-kdm now shows I have two versions
installed:

tomh> rpm -q kde-settings-kdm
kde-settings-kdm-19-23.fc19.noarch
kde-settings-kdm-19-23.1.fc19.noarch

More details in:

https://lists.fedoraproject.org/pipermail/users/2013-August/439470.html
Comment 2 Rex Dieter 2013-08-07 07:48:45 EDT
Icky, I'll try to find out if there's anything packaging-wise we can do to help get us out of the mess.

Otherwise, it looks like the only alternative may be to do:

rpm -e --noscripts kde-settings-kdm-19-23.fc19.noarch
Comment 3 Kevin Kofler 2013-08-09 17:35:35 EDT
The actual issue was already fixed, but ironically the fix only triggers the bug. (The only way to avoid triggering the bug would have been to never update kde-settings again, not really a maintainable option either.)

I don't think there's anything we can do. This sucks because the broken package slipped into F19 GA, so basically everyone with a fresh install of F19 will run into this. (The only way to completely avoid it is to install F18 instead and upgrade from there.) You need to:
rpm -e --noscripts kde-settings-kdm-19-23.fc19
IMHO, we should add this to the common F19 bugs.

*** This bug has been marked as a duplicate of bug 989145 ***
Comment 4 Tom Horsley 2013-08-09 19:56:09 EDT
And maybe add uninstalling and/or upgrading to the tests that rpms must pass before they are released?

Note You need to log in before you can comment on or make changes to this bug.