Bug 994476 - GRE breaks numerical fields on save
GRE breaks numerical fields on save
Status: CLOSED DUPLICATE of bug 975922
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: manstis
Jiri Locker
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 07:11 EDT by Jiri Locker
Modified: 2013-08-22 04:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 04:13:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Locker 2013-08-07 07:11:33 EDT
Description of problem:
1) When authoring a new rule, define a fact pattern with a constraint on numerical field (e.g. age > 30). Save the rule. The commit looks OK. Now close the rule, a confirmation asking to discard unsaved changes pops up. Accept and reopen the rule. The "greater than" operator is reset to "please choose".

2) When editing existing rule, constraints on numerical fields are completely erased. Try Bankruptcy history, change yearOfOccurence and save the rule. Check the git commit and reopen the rule, yearOfOccurence and amountOwed are gone.

Version-Release number of selected component (if applicable):
CR1 (community)
Comment 1 Jiri Locker 2013-08-22 04:13:03 EDT

*** This bug has been marked as a duplicate of bug 975922 ***

Note You need to log in before you can comment on or make changes to this bug.