Bug 994479 - RFE add configuration file verifier and DTD specificaton
RFE add configuration file verifier and DTD specificaton
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Thomas Woerner
Tomas Dolezal
: FutureFeature
Depends On:
Blocks: 980210
  Show dependency treegraph
 
Reported: 2013-08-07 07:14 EDT by Tomas Dolezal
Modified: 2015-11-19 07:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:59:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dolezal 2013-08-07 07:14:41 EDT
Description of problem:
rfe: add xml configuration validator/lint, add DTD for configuration file

Version-Release number of selected component (if applicable):
firewalld-0.3.4-1

How reproducible:
rfe

Expected results:


Additional info:
requested by participant on a usability testday
Comment 2 Jiri Popelka 2013-08-16 11:54:15 EDT
There's been also an upstream ticket for this:
https://fedorahosted.org/firewalld/ticket/8

I've actually already had some XML Schemas,
but have no idea how to correctly incorporate them:
https://git.fedorahosted.org/cgit/firewalld.git/tree/config/xmlschema
Comment 7 Thomas Woerner 2014-09-29 19:50:21 EDT
Moving to 7.2
Comment 9 Jiri Popelka 2015-04-01 04:40:19 EDT
Since upstream version 0.3.13, we've been including XSD (XML Schema Definition) files in the tarball. These are installed into /usr/lib/firewalld/xmlschema/
Comment 10 Thomas Woerner 2015-07-06 09:58:12 EDT
The xml parser in python-libs (expat) does not support validation with DTD or schema. The error from the xml parser is "SAXNotSupportedException: expat does not support validation"

A switch to a another parser is not possible easily. Therefore this request can not get fulfilled with integrated validation.

A possible solution is to do manual verification with an external tool, like for example xmllint from the libxml2 package using the schema files from comment 2.
Comment 11 Thomas Woerner 2015-07-06 15:37:10 EDT
The requirement for libxml2 will not be added on top of the existing requirements.

The check script provides information about missing xmllint and how to fix this.
Comment 19 errata-xmlrpc 2015-11-19 07:59:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2422.html

Note You need to log in before you can comment on or make changes to this bug.