Bug 994495 - virt-sandbox-service can't delete running container
virt-sandbox-service can't delete running container
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt-sandbox (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 07:57 EDT by zhe peng
Modified: 2014-06-13 08:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: libvirt-sandbox-0.5.0-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:06:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhe peng 2013-08-07 07:57:06 EDT
Description of problem:
virt-sandbox-service can't delete a running container.

Version-Release number of selected component (if applicable):
libvirt-sandbox-0.5.0-1.el7.x86_64
libvirt-1.1.1-2.el7.x86_64
kernel-3.10.0-6.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1:create&start a contariner

2:#virt-sandbox-service delete apache01
# echo $?
0
3:#virsh -c lxc:/// list --all
 Id    Name                           State
----------------------------------------------------
 5558  apache01                       running


Actual results:
container still in running status

Expected results:
delete container

Additional info:
Comment 1 Wayne Sun 2013-08-07 08:06:34 EDT
Fix in upstream:

https://www.redhat.com/archives/libvir-list/2013-August/msg00288.html

commit 5963dea4662219058e47d678ba9a3c98b67fceb6
Author: Wayne Sun <gsun@redhat.com>
Date:   Wed Aug 7 19:50:41 2013 +0800

    Fix delete of running containers
    
    The stop function is removed since 0.5.0, update delete function
    using virsh destroy to stop container.
    
    Signed-off-by: Wayne Sun <gsun@redhat.com>
Comment 3 zhe peng 2013-08-13 23:15:37 EDT
verify with build:
libvirt-sandbox-0.5.0-2.el7.x86_64
libvirt-1.1.1-2.el7.x86_64
kernel-3.10.0-6.el7.x86_64

step:
1:create&start a contariner

2:#virt-sandbox-service delete apache01
/usr/bin/virt-sandbox-service: Cannot delete running container

3:#virsh -c lxc:/// destroy apache01
Domain apache01 destroyed

# virt-sandbox-service delete apache01 ;echo $?
0

verification passed. move to verified.
Comment 5 Ludek Smid 2014-06-13 08:06:23 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.