Bug 9945 - tcpdump and promiscuous mode
Summary: tcpdump and promiscuous mode
Status: CLOSED DUPLICATE of bug 6464
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcpdump   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-03 23:54 UTC by Gordon Messmer
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-04 17:33:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gordon Messmer 2000-03-03 23:54:57 UTC
tcpdump doesn't seem to put an interface into promiscuous mode unless you
use the -p flag.  However, the man page for tcpdump says:

-p     _Don't_  put  the  interface  into promiscuous mode.

Only after using the '-p' flag does the dmesg report that the interface was
put into promiscuous mode.

Further, even whether the device is in promiscuous mode or not, tcpdump
only dumps traffic that comes to a local interface (or is broadcast). This
behavior is consistant among libpcap apps (ngrep, etherape), so maybe this
bug is kernel related?? (running kernel 2.2.15-pre2)

Comment 1 Jeff Johnson 2000-03-04 17:33:59 UTC
The man page is wrong and will be fixed.

*** This bug has been marked as a duplicate of 6464 ***


Note You need to log in before you can comment on or make changes to this bug.