Bug 99450 - Segmentation Fault: sched.h:-21406: internal error: while trying to compile from kernel-source-2.4.20-18.9
Summary: Segmentation Fault: sched.h:-21406: internal error: while trying to compile f...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-19 21:13 UTC by asd
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 20:11:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xconfig file for kernel configuration (26.02 KB, text/plain)
2003-07-19 21:19 UTC, asd
no flags Details

Description asd 2003-07-19 21:13:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Trying to recompile kernel from kernel-source-2.4.20-18.9. Problem is consistent
(I keep getting the error at the same point). Will not compile.

Version-Release number of selected component (if applicable):
kernel-source-2.4.20-18.9

How reproducible:
Always

Steps to Reproduce:
1. make xconfig
2. make dep
3. make clean
4. make zImage - this step never completes succesfully
    

Actual Results:  make[2]: Entering directory
`/usr/src/linux-2.4.20-18.9/drivers/block'
make all_targets
make[3]: Entering directory `/usr/src/linux-2.4.20-18.9/drivers/block'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.20-18.9/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i686   -nostdinc -iwithprefix include
-DKBUILD_BASENAME=ll_rw_blk  -DEXPORT_SYMTAB -c ll_rw_blk.c
In file included from ll_rw_blk.c:14:
/usr/src/linux-2.4.20-18.9/include/linux/sched.h:-21406: internal error:
Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [ll_rw_blk.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.20-18.9/drivers/block'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.20-18.9/drivers/block'
make[1]: *** [_subdir_block] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-18.9/drivers'
make: *** [_dir_drivers] Error 2


Expected Results:  kernel should have compiled with no errors

Additional info:

Comment 1 asd 2003-07-19 21:19:35 UTC
Created attachment 93019 [details]
xconfig file for kernel configuration

Comment 2 Jakub Jelinek 2003-07-21 09:02:10 UTC
If the problem is really reproduceable, I need preprocessed source on which
you can reproduce it (ie. add -save-temps to the above command and attach
here ll_rw_blk.i if you can reproduce it by running
gcc -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer \
    -mpreferred-stack-boundary=2 -march=i686 -S ll_rw_blk.i

Comment 3 Jakub Jelinek 2004-10-03 20:11:24 UTC
No testcase provided and the kernel has certainly built since then.
Assuming hardware problems.


Note You need to log in before you can comment on or make changes to this bug.