Bug 994505 - New version request
New version request
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libtommath (Show other bugs)
rawhide
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Simone Caronni
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 615088
  Show dependency treegraph
 
Reported: 2013-08-07 08:18 EDT by Christopher Meng
Modified: 2013-08-31 15:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: libtommath-0.42.0-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 17:30:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
negativo17: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Christopher Meng 2013-08-07 08:18:11 EDT
I need to unbundle dropbear bundled libraries.

Please update to the latest for all branches. 0.42 contains a CVE fix.
Comment 1 Simone Caronni 2013-08-08 10:58:16 EDT
libtommath has been built, waiting on another component and will push updates for all branches.
Comment 2 Fedora Update System 2013-08-08 11:29:17 EDT
libtommath-0.42.0-2.el6,libtomcrypt-1.17-20.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/libtommath-0.42.0-2.el6,libtomcrypt-1.17-20.el6
Comment 3 Fedora Update System 2013-08-08 11:29:46 EDT
libtommath-0.42.0-2.fc18,libtomcrypt-1.17-20.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libtommath-0.42.0-2.fc18,libtomcrypt-1.17-20.fc18
Comment 4 Fedora Update System 2013-08-08 11:30:20 EDT
libtommath-0.42.0-2.fc19,libtomcrypt-1.17-20.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libtommath-0.42.0-2.fc19,libtomcrypt-1.17-20.fc19
Comment 5 Christopher Meng 2013-08-08 21:02:03 EDT
Yeah, if you can change stable karma to 1 I can push them to stable today.

But you didn't.
Comment 6 Simone Caronni 2013-08-09 03:19:41 EDT
Can you test all branches?
Comment 7 Christopher Meng 2013-08-09 05:00:46 EDT
I can test f19 and el6.

dropbear need its latest version, which was released almost 3 years ago. I tihnk there should have no problem.
Comment 8 Fedora Update System 2013-08-09 13:06:07 EDT
Package libtommath-0.42.0-2.fc19, libtomcrypt-1.17-20.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libtommath-0.42.0-2.fc19 libtomcrypt-1.17-20.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14482/libtommath-0.42.0-2.fc19,libtomcrypt-1.17-20.fc19
then log in and leave karma (feedback).
Comment 9 Christopher Meng 2013-08-14 00:22:00 EDT
Hi,

I don't know how you installed the headers, comparing with Debian I found this library has different location.

http://pkgs.org/debian-sid/debian-main-amd64/libtommath-dev_0.42.0-1_amd64.deb.html

http://pkgs.org/fedora-rawhide/fedora-i386/libtommath-devel-0.42.0-2.fc20.i686.rpm.html

And because dropbear author develops software under non-Fedora OS, and since this library is not used by any other softwares in Fedora, will you change the location?

If not I will write patches again...
Comment 10 Simone Caronni 2013-08-18 14:04:26 EDT
(In reply to Christopher Meng from comment #9)
> And because dropbear author develops software under non-Fedora OS, and since
> this library is not used by any other softwares in Fedora, will you change
> the location?

I inherited ownership of the working package a couple of months ago so I did not made any bug change to it. I don't see any problem in this, I just need to simplify the spec file; both tommath and tomcrypt have very specific prefixes in header files.
Comment 11 Simone Caronni 2013-08-18 14:17:15 EDT
(In reply to Simone Caronni from comment #10)
> not made any bug change to it.

*big* change, sorry.
Comment 12 Fedora Update System 2013-08-18 17:30:07 EDT
libtommath-0.42.0-2.fc18, libtomcrypt-1.17-20.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-08-18 17:38:26 EDT
libtommath-0.42.0-2.fc19, libtomcrypt-1.17-20.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-08-31 15:17:45 EDT
libtommath-0.42.0-2.el6, libtomcrypt-1.17-20.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.