This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 994516 - Installation instructions of BRMS on EAP 6
Installation instructions of BRMS on EAP 6
Status: CLOSED DUPLICATE of bug 923171
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: doc-BRMS_Getting_Started_Guide (Show other bugs)
BRMS 5.3.1
All All
unspecified Severity high
: ---
: ---
Assigned To: lcarlon
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 08:36 EDT by Marc Zottner
Modified: 2013-08-07 18:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:55:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Zottner 2013-08-07 08:36:02 EDT
Document URL: https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_BRMS_Platform/5/html-single/BRMS_Getting_Started_Guide/index.html#Installing_on_JBoss_Enterprise_Application_Platform_61

Section Number and Name: 

2.4. Installing on JBoss Enterprise Application Platform 6

Describe the issues: 

There are several major errors in the description:

(1) You need to create two property files in JBOSS_HOME/standalone/configuration
	brms-users.properties
	admin=admin	
	brms-roles.properties
        admin=admin, user, manager, administrator

(2) The mentioned jboss-brms.war actually is in jboss-brms-manager-ee6.zip (and not in jboss-brms-manager.zip) 
See ... "Extract jboss-brms.war from the jboss-brms-manager.zip archive"

(3) "designer.war.dodeploy" instead of "desginer.war.dodeploy"

(4) Here is probably a correct datasource:

<subsystem xmlns="urn:jboss:domain:datasources:1.1"> 
  <datasources> 
    <datasource jndi-name="java:jboss/datasources/jbpmDS"
                pool-name="jbpmDS" enabled="true" use-java-context="true"> 
       <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1</connection-url> 
       <driver>h2</driver> 
       <security> 
         <user-name>sa</user-name> 
         <password>sa</password> 
       </security> 
     </datasource> 
     <drivers> 
       <driver name="h2" module="com.h2database.h2"> 
         <xa-datasource-class>
           org.h2.jdbcx.JdbcDataSource
         </xa-datasource-class> 
       </driver> 
     </drivers> 
   </datasources> 
</subsystem>  

Suggestions for improvement: 

At the end of the installation, the BRMS platform does not even run. The installation instructions have to be checked again.


Additional information:  -
Comment 1 lcarlon 2013-08-07 18:55:43 EDT
Hi Marc,

I'm marking this as a duplicate of bug923171. I'll push that updated document today. Refer to the adding users section for the info in point 1.

*** This bug has been marked as a duplicate of bug 923171 ***

Note You need to log in before you can comment on or make changes to this bug.