Bug 994547 - pand runs as initrc_t
pand runs as initrc_t
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On: nopolicy
Blocks: 848829 1040974
  Show dependency treegraph
 
Reported: 2013-08-07 09:37 EDT by Milos Malik
Modified: 2014-06-17 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-70.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:17:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2013-08-07 09:37:17 EDT
# rpm -qa selinux-policy\*
selinux-policy-targeted-3.12.1-69.el7.noarch
selinux-policy-mls-3.12.1-69.el7.noarch
selinux-policy-devel-3.12.1-69.el7.noarch
selinux-policy-minimum-3.12.1-69.el7.noarch
selinux-policy-3.12.1-69.el7.noarch
selinux-policy-doc-3.12.1-69.el7.noarch
# sestatus 
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   enforcing
Mode from config file:          enforcing
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      28
#

# cat /etc/sysconfig/pand 
#PANDARGS='--listen --role NAP'
PANDARGS='--search --cache --persist'
# service pand start
Starting pand (via systemctl):                             [  OK  ]
# service pand status
pand.service - LSB: Bluetooth Personal Area Networking Daemon.
   Loaded: loaded (/etc/rc.d/init.d/pand)
   Active: active (running) since Wed 2013-08-07 15:29:11 CEST; 2s ago
  Process: 22352 ExecStop=/etc/rc.d/init.d/pand stop (code=exited, status=0/SUCCESS)
  Process: 23754 ExecStart=/etc/rc.d/init.d/pand start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/pand.service
           └─23757 /usr/bin/pand --search --cache --persist

Aug 07 15:29:11 rhel70 systemd[1]: Starting LSB: Bluetooth Personal Area Ne.....
Aug 07 15:29:11 rhel70 pand[23754]: Starting pand: [  OK  ]
Aug 07 15:29:11 rhel70 pand[23757]: Bluetooth PAN daemon version 4.101
Aug 07 15:29:11 rhel70 pand[23757]: Inquiring
Aug 07 15:29:11 rhel70 pand[23757]: Inquiry failed. No such device(19)
Aug 07 15:29:11 rhel70 systemd[1]: Started LSB: Bluetooth Personal Area Net.....
# ps -efZ | grep pand
system_u:system_r:initrc_t:s0   root     23757     1  0 15:29 ?        00:00:00 /usr/bin/pand --search --cache --persist
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 23775 23669  0 15:29 pts/0 00:00:00 grep --color=auto pand
#

Expected results:
 * /usr/bin/pand is labelled bluetooth_exec_t
 * pand process runs as bluetooth_t
Comment 2 Ludek Smid 2014-06-13 09:17:52 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.