Bug 994556 - Ant 1.9 has fewer jars in classpath, which makes building visualvm from source fail.
Ant 1.9 has fewer jars in classpath, which makes building visualvm from sourc...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Srb
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 992858 1004016
  Show dependency treegraph
 
Reported: 2013-08-07 09:49 EDT by Severin Gehwolf
Modified: 2013-09-03 13:34 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.9.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1004016 (view as bug list)
Environment:
Last Closed: 2013-08-09 03:23:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff of jars in classpath for 1.8 and 1.9 respectively (620 bytes, patch)
2013-08-07 09:49 EDT, Severin Gehwolf
no flags Details | Diff

  None (edit)
Description Severin Gehwolf 2013-08-07 09:49:00 EDT
Created attachment 783930 [details]
Diff of jars in classpath for 1.8 and 1.9 respectively

Description of problem:
The visualvm package fails to build in rawhide. See bug 992858.

Version-Release number of selected component (if applicable):
ant-1.9.2-3.fc20.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Try to build visualvm with ant-1.8.4-6.fc19.noarch (works)
2. Try to build visualvm with ant-1.9.2-3.fc20.noarch (fails)

Actual results:
Compilation of visualvm fails.

Expected results:
Compilation of visualvm works.

Additional info:
I've done some digging and as it turns out ant 1.9 has fewer jars in the classpath via the script (/usr/bin/ant) it uses for launching. Patch is attached with the differences. Obtained via --execdebug passed to the script. In particular, ant 1.9 doesn't have /usr/share/java/xml-commons-apis.jar in the classpath which is the root cause why visulvm fails to build. Is this intentional? If so why?
Comment 1 Michal Srb 2013-08-08 02:10:17 EDT
Hi Severin,

Thanks for reporting this. Removing xml-commons-apis from classpath in 1.9 was indeed intentional. It was due to bug #838711. And it looks like we didn't realize that xerces provides also Traversal Element API, but openjdk doesn't. That's the reason why your package fails to build. I will try to find solution that will satisfy both you and #838711. For now, I've reverted changes in 1.9 classpath so you should be able to build your package.
Comment 2 Michal Srb 2013-08-09 03:23:47 EDT
I think that this problem should be solved in 1.9.2-4. Closing.

Note You need to log in before you can comment on or make changes to this bug.