Bug 994589 - libvirt prints gcc instead of $CC at configure time
libvirt prints gcc instead of $CC at configure time
Status: CLOSED NEXTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 10:40 EDT by Agostino Sarubbo
Modified: 2013-08-07 11:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 11:48:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build log (1.17 MB, text/x-log)
2013-08-07 11:08 EDT, Agostino Sarubbo
no flags Details

  None (edit)
Description Agostino Sarubbo 2013-08-07 10:40:51 EDT
During the compilation of libvirt, I just see a very minor bug, it prints gcc instead of $CC (in my case x86_64-pc-linux-gnu-gcc)

checking whether gcc -Wformat allows NULL strings... yes
Comment 1 Daniel Berrange 2013-08-07 10:59:36 EDT
You really must provide more useful information when reporting bugs.  Please tell us what libvirt vesion you are using, what platform you're building on, and include the full output of 'configure' as an attachment.
Comment 2 Agostino Sarubbo 2013-08-07 11:08:51 EDT
Created attachment 783968 [details]
build log

Portage 2.1.13.2 (default/linux/amd64/13.0, gcc-4.6.3, glibc-2.15-r3, 3.8.13-gentoo x86_64)                                                                                         
=================================================================                                                                                                                   
                        System Settings                                                                                                                                             
=================================================================                                                                                                                   
System uname: Linux-3.8.13-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.2                                                                                   
KiB Mem:     2055892 total,    512552 free                                                                                                                                          
KiB Swap:    2263820 total,   2261700 free                                                                                                                                          
Timestamp of tree: Wed, 07 Aug 2013 12:30:01 +0000                                                                                                                                  
ld GNU ld (GNU Binutils) 2.23.1                                                                                                                                                     
app-shells/bash:          4.2_p45                                                                                                                                                   
dev-lang/python:          2.7.5, 3.2.5-r1                                                                                                                                           
dev-util/cmake:           2.8.10.2-r2                                                                                                                                               
sys-apps/baselayout:      2.2                                                                                                                                                       
sys-apps/openrc:          0.11.8                                                                                                                                                    
sys-apps/sandbox:         2.6-r1                                                                                                                                                    
sys-devel/autoconf:       2.13, 2.69                                                                                                                                                
sys-devel/automake:       1.11.6, 1.12.6                                                                                                                                            
sys-devel/binutils:       2.23.1                                                                                                                                                    
sys-devel/gcc:            4.6.3                                                                                                                                                     
sys-devel/gcc-config:     1.7.3                                                                                                                                                     
sys-devel/libtool:        2.4-r1                                                                                                                                                    
sys-devel/make:           3.82-r4                                                                                                                                                   
sys-kernel/linux-headers: 3.7 (virtual/os-headers)                                                                                                                                  
sys-libs/glibc:           2.15-r3                                                                                                                                                   
Repositories: gentoo                                                                                                                                                                
ACCEPT_KEYWORDS="amd64"                                                                                                                                                             
ACCEPT_LICENSE="*"                                                                                                                                                                  
CBUILD="x86_64-pc-linux-gnu"                                                                                                                                                        
CFLAGS="-march=native -O2 -g0 -pipe"                                                                                                                                                
CHOST="x86_64-pc-linux-gnu"                                                                                                                                                         
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --keep-going y -1"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms sign split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://192.168.1.10/ http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb bzip2 cli consolekit cracklib crypt cxx dbus dri fortran gdbm iconv kde minizip mmx modules mp3 mudflap multilib ncurses nls nptl opengl openmp pam pcre policykit qt3support qt4 readline semantic-desktop session sse sse2 ssl symlink tcpd unicode zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="am fil zh af ca cs da de el es et gl hu nb nl pl pt ro ru sk sl sv uk bg cy en eo fo ga he id ku lt lv mk ms nn sw tn zu ja zh_TW en_GB pt_BR ko zh_CN ar en_CA fi kk oc sr tr fa wa nds as be bn bn_BD bn_IN en_US es_AR es_CL es_ES es_MX eu fy fy_NL ga_IE gu gu_IN hi hi_IN is ka kn ml mr nn_NO or pa pa_IN pt_PT rm si sq sv_SE ta ta_LK te th vi ast dz km my om sh ug uz ca@valencia sr@ijekavian sr@ijekavianlatin sr@latin csb hne mai se es_LA fr_CA zh_HK br la no es_CR et_EE sr_CS bo hsb hy mn sr@Latn lb ne bs tg uz@cyrillic xh be_BY brx ca_XV dgo en_ZA gd kok ks ky lo mni nr ns pap ps rw sa_IN sat sd ss st sw_TZ ti ts ve mt ia az me tl ak hy_AM lg nso son ur_PK it fr nb nb_NO hr nan ur tk cs_CZ da_DK de_1901 de_CH en_AU lt_LT pl_PL sa sk_SK th_TH ta_IN tt sco ha mi ven ar_SY el_GR ro_RO ru_RU sl_SI uk_UA vi_VN ar_SY te_IN de_DE es_VE fa_IR fr_FR hu_HU id_ID it_IT ja_JP ka_GE nl_NL sr_BA sr_RS ca_ES fi_FI he_IL jv ru_gold yi eu_ES chr jp bg_BG ko_KR" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3 php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-emulation/libvirt-1.1.1-r1 was built with the following:
USE="caps libvirtd macvtap nls policykit qemu udev vepa -audit -avahi -firewalld -fuse -iscsi -lvm -lxc -nfs -numa -openvz -parted -pcap -phyp -python -rbd -sasl (-selinux) -systemd -uml -virt-network -virtualbox -xen" PYTHON_SINGLE_TARGET="python2_7 -python2_5 -python2_6" PYTHON_TARGETS="python2_7 -python2_5 -python2_6"
Comment 3 Eric Blake 2013-08-07 11:36:12 EDT
The issue is cosmetic - there are merely two strings in m4/virt-compile-warnings.m4 that hard-code the string gcc instead of referring to the more generic "C compiler" or "$CC" terminology.  A patch is very trivial, but even without the patch, libvirt is still behaving correctly for your alternative compiler.
Comment 4 Agostino Sarubbo 2013-08-07 11:39:35 EDT
(In reply to Eric Blake from comment #3)
> The issue is cosmetic - there are merely two strings in
> m4/virt-compile-warnings.m4 that hard-code the string gcc instead of
> referring to the more generic "C compiler" or "$CC" terminology.  A patch is
> very trivial, but even without the patch, libvirt is still behaving
> correctly for your alternative compiler.

I know, infact the summary says print instead of use.

The behavior is correct, the config.log uses the correct $CC, but it prints wrong.
Comment 5 Eric Blake 2013-08-07 11:48:14 EDT
It would have been faster to propose a patch than to jump through BZ hoops trying to get someone else to understand your complaint...

Libvirt 1.1.2 will contain this patch.

commit ff38690be97088a399d3a7eab4a3b07f9194ab70
Author: Eric Blake <eblake@redhat.com>
Date:   Wed Aug 7 09:44:52 2013 -0600

    maint: the compiler is not always named gcc
    
    https://bugzilla.redhat.com/show_bug.cgi?id=994589 complained that
    even when using a cross-compiler not named 'gcc', the configure
    output confusingly referred to gcc.
    
    * m4/virt-compile-warnings.m4 (LIBVIRT_COMPILE_WARNINGS): Use a
    more generic statement in configure output.
    
    Signed-off-by: Eric Blake <eblake@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.