Bug 994593 - new "--nogpgsigs" argument to install_packages
new "--nogpgsigs" argument to install_packages
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Duryee
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-07 10:45 EDT by Chris Duryee
Modified: 2013-10-01 07:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:16:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2013-08-07 10:45:44 EDT
Description of problem:

Currently, install_packages does not work if the component RPMs are not signed. There are two cases when the RPMs won't be signed:

 * ISO is not a release candidate
 * user wants to roll their own packages and install them via install_packages

To allow for unsigned rpms to work, we can add an optional "--nogpgsigs" argument to the install_packages script. This will pass "--nogpgcheck" to the yum command when installing packages.
Comment 1 Chris Duryee 2013-08-07 16:05:31 EDT
571c9162a0a52b8c4dd86ecb0d77d0d99f8cbead katello-misc

there is no version number, this script gets baked into the ISO via other processes.
Comment 2 Chris Duryee 2013-08-07 16:39:55 EDT
oops i was a bit hasty in changing this to ON_QA. Moving back to MODIFIED state.
Comment 4 sthirugn@redhat.com 2013-08-20 18:04:42 EDT
Verified.

# ./install_packages --nogpgsigs
This script will install the katello packages on the current machine.
   - Ensuring we are in an expected directory.
   - Creating a Repository File
   - Checking to see if Katello is already installed.
   - Importing the gpg key.
   - WARNING: Package GPG signatures will be ignored!
   - katello-headpin-all is not yet installed, installing it.
   - Removing the repository file.

Install is complete. Please run katello-configure.

Version Tested:
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 6 errata-xmlrpc 2013-10-01 07:16:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.