Bug 994600 - [vdsm] SuperVdsm fails to start due to ValueError: ipaddr rhevm is not properly defined
[vdsm] SuperVdsm fails to start due to ValueError: ipaddr rhevm is not proper...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
All Linux
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Assaf Muller
Gadi Ickowicz
network
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 11:05 EDT by Gadi Ickowicz
Modified: 2016-02-10 14:55 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:30:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amuller: needinfo-


Attachments (Terms of Use)
engine, vdsm, supervdsm logs (3.58 MB, application/x-tar)
2013-08-07 11:05 EDT, Gadi Ickowicz
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17789 None None None Never
oVirt gerrit 17793 None None None Never

  None (edit)
Description Gadi Ickowicz 2013-08-07 11:05:07 EDT
Created attachment 783965 [details]
engine, vdsm, supervdsm logs

Description of problem:
Adding a host to rhevm failed due to supervdsm failure to start. This is caused by attempting to configure routes and failing. supervdsm attempts to configure source route with parameters:
Configuring gateway - ip: 10.35.164.143, network: 10.35.164.0/24, subnet: 255.255.255.0, gateway: rhevm, table: 170108047, device: rhev

gateway = rhevm is passed, and this fails because 'rhevm' is not a valid ip address

Version-Release number of selected component (if applicable):
vdsm-4.12.0-rc3.13.git06ed3cc.el6ev.x86_64

How reproducible:
? happened during host installation in automated test

Steps to Reproduce:
1. Attempt to add host

Actual results:
Supervdsm fails to start

Expected results:
supervdsm should start

Additional info:
Comment 1 Assaf Muller 2013-08-08 12:13:36 EDT
Fixed on upstream vdsm master and ovirt-3.3 branches.
Comment 4 Gadi Ickowicz 2013-08-25 04:47:35 EDT
verified - did not reproduce in automated tests on is11.
Comment 5 Charlie 2013-11-27 19:34:02 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:30:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.