Bug 994620 - Need better messaging on rhsm-icon when partial subscription exsists on a fully compliant machine
Summary: Need better messaging on rhsm-icon when partial subscription exsists on a ful...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 6.5
Assignee: Carter Kozak
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel65
TreeView+ depends on / blocked
 
Reported: 2013-08-07 15:57 UTC by Rehana
Modified: 2013-11-21 21:27 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: reword tooltip message Reason: Original wording was confusing to users. Result (if any):
Clone Of:
Environment:
Last Closed: 2013-11-21 21:27:27 UTC


Attachments (Terms of Use)
RHSM-ICON status (401.55 KB, image/png)
2013-09-06 14:15 UTC, Sharath Dwaral
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1659 normal SHIPPED_LIVE subscription-manager and python-rhsm bug fix and enhancement update 2013-11-20 21:53:10 UTC

Description Rehana 2013-08-07 15:57:40 UTC
Description of problem:
Observed during the verification of the  bug https://bugzilla.redhat.com/show_bug.cgi?id=983281, that the tool tip message on rhsm-icon says "Partially entitled products" when it should be saying "Partially entitled subscriptions"

Version-Release number of selected component (if applicable):
rpm -qa | grep subscr
subscription-manager-migration-1.8.18-1.el5
subscription-manager-debuginfo-1.8.18-1.el5
subscription-manager-gui-1.8.18-1.el5
subscription-manager-1.8.18-1.el5
subscription-manager-firstboot-1.8.18-1.el5

How reproducible:
3/3

Steps to Reproduce:
1.Attach subscriptions to make the system fully compliant
2.Now attach a partial subscription 
3.Verify the rhsm-icon getting raised with correct message or not

Actual results:
Currently tool-tip message is displaying "Partially entitled products" 

Expected results:
Should be displaying "Partially entitled subscriptions" 

Additional info:

Comment 1 Carter Kozak 2013-08-07 16:00:48 UTC
1.Attach subscriptions to make the system fully compliant

If the system has a partial stack attached, or arch-mismatched entitlement(s), the system is not considered "fully compliant"
All of the installed products, however, can still be fully compliant.

I'll make the string change.

Comment 2 Carter Kozak 2013-08-19 19:52:40 UTC
commit 9cf0198d7bc82da0e02a5080ad3f1da9338d6af8
Author: ckozak <ckozak@redhat.com>
Date:   Mon Aug 19 14:01:50 2013 -0400

    994620: reword tooltip message

Comment 3 Bryan Kearney 2013-09-03 18:23:19 UTC
this will be available as of 1.9.6

Comment 4 Sharath Dwaral 2013-09-06 14:15:57 UTC
Created attachment 794779 [details]
RHSM-ICON status

Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.9.5-1.el6.x86_64
subscription-manager-migration-1.9.5-1.el6.x86_64
python-rhsm-1.9.4-1.el6.x86_64
subscription-manager-gui-1.9.5-1.el6.x86_64
subscription-manager-firstboot-1.9.5-1.el6.x86_64

Setup:

1. Let system be fully compliant
2. Add a subscription that does not match the system
3. HOVER the mouse over rhsm-icon on the top right corner of screen (DO NOT CLICK)

Verification:

Please see attachment

VERIFIED

Comment 5 errata-xmlrpc 2013-11-21 21:27:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html


Note You need to log in before you can comment on or make changes to this bug.