Bug 994661 - [GSS] (6.3.0) Custom logging formatters
Summary: [GSS] (6.3.0) Custom logging formatters
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging   
(Show other bugs)
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR2
: EAP 6.3.0
Assignee: James Perkins
QA Contact: Nikoleta Ziakova
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-07 17:54 UTC by Kyle Lape
Modified: 2018-12-05 16:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
This release of JBoss EAP 6 introduces the ability for users to create custom logging formatters for use in any handler via the command line interface or configuration XML. Handlers now override `setFormatter(...)` and use the custom formatter.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 15:41:03 UTC
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1188 Major Closed allow custom-formatter configuration 2018-01-09 10:58 UTC

Description Kyle Lape 2013-08-07 17:54:21 UTC
Currently the only formatter available in EAP 6 is the "pattern-formatter".  This feature will allow customers to create their own custom formatter and use it in any handler via the CLI and/or jboss config XML.

Comment 3 James Perkins 2013-09-19 19:42:49 UTC
This will unfortunately not make it into EAP 6.2 due to time constraints and a rather significant change to the management model.

Comment 5 Petr Kremensky 2014-03-11 12:05:37 UTC
Verified on EAP 6.3.0.DR2.

Comment 7 Scott Mumford 2014-05-30 04:11:54 UTC
Added draft release notes text.


Note You need to log in before you can comment on or make changes to this bug.