Bug 994671 - mirall-1.3.0-1.fc19.x86_64: SELinux permissions for sync-exclude.lst
mirall-1.3.0-1.fc19.x86_64: SELinux permissions for sync-exclude.lst
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mirall (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Joseph Marrero
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 14:22 EDT by Paolo Bernardi
Modified: 2013-09-13 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: mirall-1.4.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 22:36:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bernardi 2013-08-07 14:22:15 EDT
Description of problem:

Mirall, the ownCloud desktop sync client, supports excluding some file patterns from the synchronization process by editing a file. By default, with SELinux enabled, the "open" calls to that file return an ENOTBLK (Block device required) error:

open("/home/rnd/.local/share/data/ownCloud/sync-exclude.lst", O_RDONLY|O_CLOEXEC) = 15
open("/home/rnd/.local/share/data/ownCloud/exclude.lst", O_RDONLY|O_CLOEXEC) = 15
open("/etc/ownCloud/sync-exclude.lst", O_RDONLY|O_CLOEXEC) = 15


Version-Release number of selected component (if applicable):

mirall-1.3.0-1.fc19.x86_64

How reproducible:

Just create a sync-exclude.lst file and grep "exclude" in Mirall's strace

Steps to Reproduce:
1. create a /etc/ownCloud/sync-exclude.lst file
2. strace owncloud 2> ~/owncloud.strace
3. grep exclude ~/owncloud.strace

Actual results:

A few open calls returning 15 (ENOTBLK)

Expected results:

The open calls should return 0.
Comment 1 Fedora Update System 2013-09-04 12:43:43 EDT
mirall-1.4.0-2.fc19,owncloud-csync-0.90.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mirall-1.4.0-2.fc19,owncloud-csync-0.90.0-1.fc19
Comment 2 Fedora Update System 2013-09-04 21:41:32 EDT
Package mirall-1.4.0-2.fc19, owncloud-csync-0.90.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mirall-1.4.0-2.fc19 owncloud-csync-0.90.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15831/mirall-1.4.0-2.fc19,owncloud-csync-0.90.0-1.fc19
then log in and leave karma (feedback).
Comment 3 Paolo Bernardi 2013-09-05 08:51:42 EDT
I re-did the original tests and this issue seems to be fixed with the updates mirall-1.4.0-2.fc19, owncloud-csync-0.90.0-1.fc19
Comment 4 Fedora Update System 2013-09-13 22:36:50 EDT
mirall-1.4.0-2.fc19, owncloud-csync-0.90.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.