Bug 994679 - Lifecycle hooks for Gluster-SMB and RHSC use different values
Lifecycle hooks for Gluster-SMB and RHSC use different values
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kanagaraj
Depends On:
  Show dependency treegraph
Reported: 2013-08-07 14:38 EDT by jhoffer
Modified: 2016-04-18 06:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: bb9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-23 18:25:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18071 None None None Never

  None (edit)
Description jhoffer 2013-08-07 14:38:40 EDT
Description of problem:
Lifecycle hooks for Gluster-SMB and RHSC use different values.  RHSC sets user.cifs to "on" and hooks look for "enable" and "disable".

Version-Release number of selected component (if applicable):
RHS 2.1 (glusterfs built on Aug  6 2013 13:47:26)
RHSC bb1 (from http://jenkins.lab.eng.blr.redhat.com/rhsc/bb1/)

How reproducible:
Any time a gluster volume is started, stopped, or user.cifs is set from RHSC (or command line).

Steps to Reproduce:
1. Create a gluster volume from RHSC.
2. Note default value for user.cifs is "on"
3. Note lifecycle scripts in /var/lib/glusterd/hooks/1/{set,start,stop} use "disable" and "enable" as values for user.cifs.

Actual results:
RHSC and hooks need to use same values, or hooks do not trigger.   S30samba-set.sh will not work with "on" or "off" as RHSC default value suggests.

Expected results:
All scripts should trigger appropriately, RHSC needs to set default appropriately, AND/OR RHSC Volume "Edit Option" dialog needs to indicate what the supported values are.

Additional info:
start/post/S30samba-start.sh works because it only checks the value is NOT "disable".  stop/pre/S30samba-stop.sh doesn't check these values so it always works. set/post/S30samba-set.sh doesn't work unless user knows what values to use i.e. enable/disable, which are dissimilar to RHSC default of "on".  Additionally gluster does not do any value checking on user.cifs, any string is accepted.
Comment 2 jhoffer 2013-08-07 15:06:55 EDT
Additional information: Un-checking CIFS box in "Create Volume" dialog sets user.cifs to "off" which is also ignored by all lifecycle hooks.
Comment 3 Sahina Bose 2013-08-08 01:35:24 EDT
During volume creation, user.cifs value needs to be changed to enable/disable depending on the checkbox value
Comment 4 Prasanth 2013-08-22 07:30:30 EDT
Verified as fixed in bb9

user.cifs value is now changed to enable/disable in RHS-C

[root@vm03 ~]# gluster vol info
Volume Name: vol1
Type: Distribute
Volume ID: 556b7c28-3a6e-4f53-974e-18c221aad271
Status: Started
Number of Bricks: 1
Transport-type: tcp
Brick1: vm03.lab.eng.blr.redhat.com:/tmp/1
Options Reconfigured:
auth.allow: *
user.cifs: enable
nfs.disable: off
Volume Name: vol2
Type: Replicate
Volume ID: 82d79a89-756b-49d2-8d7d-eb6d7998ffd2
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Brick1: vm03.lab.eng.blr.redhat.com:/tmp/22
Brick2: vm03.lab.eng.blr.redhat.com:/tmp/33
Options Reconfigured:
auth.allow: *
user.cifs: disable
nfs.disable: off
Comment 5 Scott Haines 2013-09-23 18:25:53 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.