Bug 994682 - The SOA installer UI hangs when creating a new admin user on RHEL6.4
The SOA installer UI hangs when creating a new admin user on RHEL6.4
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER2
: ---
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 14:45 EDT by Len DiMaggio
Modified: 2013-09-23 12:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 12:06:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fcanas: needinfo+


Attachments (Terms of Use)
Screenshot (111.50 KB, image/png)
2013-08-07 14:46 EDT, Len DiMaggio
no flags Details
Screenshot (111.50 KB, image/png)
2013-08-07 14:46 EDT, Len DiMaggio
no flags Details
Screenshot (92.68 KB, image/png)
2013-08-07 14:48 EDT, Len DiMaggio
no flags Details
Screenshot of successful installation. (254.62 KB, image/png)
2013-08-08 15:00 EDT, Francisco Canas
no flags Details

  None (edit)
Description Len DiMaggio 2013-08-07 14:45:01 EDT
Description of problem:

When running the installer on RHEL6, the installer UI hangs at the point in the installation where it creates a new admin user.

Version-Release number of selected component (if applicable):
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/JBoss-SOA-6.0.2-Installer-CI

How reproducible:
100%

Steps to Reproduce:
1. Perform an install
2. When the post-install step of creating a new admin user starts, the UI hangs

Actual results:
Installer hangs

Expected results:


Additional info:

See attached screenshots and strace file.
Comment 1 Len DiMaggio 2013-08-07 14:46:05 EDT
Created attachment 784069 [details]
Screenshot
Comment 2 Len DiMaggio 2013-08-07 14:46:37 EDT
Created attachment 784072 [details]
Screenshot
Comment 3 Len DiMaggio 2013-08-07 14:48:07 EDT
Created attachment 784073 [details]
Screenshot
Comment 4 Len DiMaggio 2013-08-07 14:49:49 EDT
Test system details:

uname -a
Linux ldimaggi.csb 2.6.32-279.19.1.el6.x86_64 #1 SMP Sat Nov 24 14:35:28 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/redhat-release 
Red Hat Enterprise Linux Workstation release 6.3 (Santiago)

java -version
java version "1.7.0_09-icedtea"
OpenJDK Runtime Environment (rhel-2.3.3.2.el6_3-x86_64)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)
Comment 5 Francisco Canas 2013-08-08 14:58:39 EDT
We've been unable to reproduce this issue. The post-install panel completes adding the user, and unpacking files, and the installation can be successfully completed without hanging.

See attached screenshot.

Maybe there are differences in environment other then RHEL and java version?
Comment 6 Francisco Canas 2013-08-08 15:00:21 EDT
Created attachment 784565 [details]
Screenshot of successful installation.
Comment 7 Len DiMaggio 2013-09-23 12:02:33 EDT
Verified fixed in ER3 (Sept 20 repin) - the issue was caused by the presence of an EAP .zip in the install dir.

Note You need to log in before you can comment on or make changes to this bug.