This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 994699 - Setting a null encoding on a OutputStreamHandler that uses setWriter sets the writer to null too
Setting a null encoding on a OutputStreamHandler that uses setWriter sets the...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: EAP 6.2.0
Assigned To: Emmanuel Hugonnet (ehsavoie)
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks: 994700
  Show dependency treegraph
 
Reported: 2013-08-07 15:34 EDT by Kyle Lape
Modified: 2014-10-25 08:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-20 03:17:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker LOGMGR-78 Major Resolved Setting an encoding on a OutputStreamHandler that uses setWriter sets the writer to null too 2014-09-02 09:02:52 EDT

  None (edit)
Description Kyle Lape 2013-08-07 15:34:54 EDT
An example is the ConsoleHandler. Using a target of CONSOLE uses the setWriter(wrap(System.console())) which sets the outputStream to null. The setEncoding() uses the outputStream then sets the writer. Since the outputStream is null due to the setWriter() being invoked, the writer is then set to null so no output is being written.
Comment 1 Emmanuel Hugonnet (ehsavoie) 2013-08-12 08:42:20 EDT
https://github.com/jboss-logging/jboss-logmanager/pull/34 sent to jboss-logmanager
Comment 2 JBoss JIRA Server 2013-09-03 23:39:30 EDT
James Perkins <jperkins@redhat.com> made a comment on jira LOGMGR-78

Pull request merged
Comment 3 Nikoleta Ziakova 2014-08-20 03:17:11 EDT
This issue is reported against older version and cannot be reproduced against latest 6.3.0. bits, which means it was fixed earlier. Therefore, we are closing this bug. Thank you for reporting this issue.

Note You need to log in before you can comment on or make changes to this bug.