Bug 994717 - Accessing SwitchYard mbeans via jconsole - operations are blocked - operation names are garbled
Accessing SwitchYard mbeans via jconsole - operations are blocked - operation...
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Keith Babo
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 16:11 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 10:46:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (205.92 KB, image/png)
2013-08-07 16:12 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-08-07 16:11:19 EDT
Description of problem:

See the attached screenshot. While accessing SwitchYard Mbeans via jconsole, the operations are greyed-out and the operation names are shown as "( p 1"

Version-Release number of selected component (if applicable):
soa-6.0.0.ER1-redhat-1.zip

How reproducible:
100%

Steps to Reproduce:
1. Install EAP 6.1, then soa-6.0.0.ER1-redhat-1.zip
2. Start up jconsole, connect to:  service:jmx:remoting-jmx://localhost:9999
3. Try to access a SwitchYard MBean, such as:
   org.switchyard.admin

Actual results:
See the attached screenshot

Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-08-07 16:12:05 EDT
Created attachment 784131 [details]
Screenshot
Comment 2 Len DiMaggio 2013-08-07 16:19:45 EDT
These errors are also written to stdout:

Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Error setting Operation panel :org.switchyard.event.EventObserver
Comment 3 Keith Babo 2013-08-07 16:49:25 EDT
A few comments here:

1) org.switchard.admin is not an MBean, it's the domain name for SwitchYard MBeans.  Not trying to be picky, just want to make sure we talk apples to apples here. :-)

2) The MBean you have selected is named Management.Local because it's only used for local access.  Gary requested this MBean to register rtgov listeners from within the same VM.  You are connecting remotely from jconsole, so no Management.Local for you!

3) Operation names are not grayed out in your screenshot.  The operation name you have selected is visible in MBeanOperationInfo next to the name field ("removeObserver").  Parameter names are not kept by default at runtime, so the lack of a parameter name is not a surprise as we are not providing our own MBeanInfo object.

4) MBeans are not registered until at least one SY application is deployed.  Deploy an app then check the org.switchyard.admin domain.

5) The errors you see in the console stdout are due to the fact that you are accessing local management interfaces from a remote client.
Comment 4 Keith Babo 2013-11-15 10:46:54 EST
This is not a bug.

Note You need to log in before you can comment on or make changes to this bug.