Bug 994721 - Subscription Asset Manager will not configure properly on a system with puppet 2.7 [NEEDINFO]
Subscription Asset Manager will not configure properly on a system with puppe...
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
1.3
All Linux
high Severity high
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2013-08-07 16:33 EDT by Jacob Hunt
Modified: 2017-06-26 16:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 16:38:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jhunt: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Jacob Hunt 2013-08-07 16:33:37 EDT
Description of problem:

Tried installing and configuring the SAM server, but our systems have a newer version of puppet than is provided by SAM. We are currently installing 2.7.5. With the newer puppet installed, the "katello-configure --deployment=sam" command is failing to complete because puppet is some how picking up some of the configuration from our system manifest when trying to configure katello. 


Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1.  Attempt to install SAM in a environment with a pre-existing puppet setup


Actual results:

The install fails because during the katello-configure it uses the existing puppet.conf and will fail with a 2.7+ puppet environment

Expected results:

For katello-configure to only access the puppet configuration it is packaged with
Comment 2 Bryan Kearney 2017-06-26 16:38:02 EDT
The release of Satellite 5.8 we are deprecating the support of Subscription Asset Manager. The release notes for 5.8 can be found at https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/pdf/release_notes/Red_Hat_Satellite-5.8-Release_Notes-en-US.pdf.

I am therefore closing out this bug as WONTFIX. If you believe this to be an error, please feel free tor each out to either Rich Jerrido or Bryan Kearney. Thank you!

Note You need to log in before you can comment on or make changes to this bug.