Bug 994727 - Samba hook script adds redundant sections in smb.conf
Samba hook script adds redundant sections in smb.conf
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
pre-release
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Raghavendra Talur
:
Depends On: 844761 852140
Blocks: 858434
  Show dependency treegraph
 
Reported: 2013-08-07 17:30 EDT by Raghavendra Talur
Modified: 2014-04-17 07:45 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 852140
Environment:
Last Closed: 2014-04-17 07:45:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-07 17:54:29 EDT
REVIEW: http://review.gluster.org/5526 (extras/hook-scripts: Don't add multiple entries in smb.conf) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Anand Avati 2013-08-07 17:57:13 EDT
COMMIT: http://review.gluster.org/5526 committed in master by Anand Avati (avati@redhat.com) 
------
commit 993001dadf3b1706816b7762749a4c4426ac86df
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Aug 8 03:19:43 2013 +0530

    extras/hook-scripts: Don't add multiple entries in smb.conf
    
    When volume is force started, there may be entry in smb.conf
    for that volume. Always check for entry before adding one.
    
    Change-Id: I44f893174a993abaa31c24c1a81bb38a58617808
    BUG: 994727
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/5526
    Reviewed-by: Anand Avati <avati@redhat.com>
    Tested-by: Anand Avati <avati@redhat.com>
Comment 3 Anand Avati 2013-10-07 03:46:23 EDT
REVIEW: http://review.gluster.org/6043 (extras/hookscripts: Fix the multiple entries in smb.conf problem.) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 4 Anand Avati 2013-10-07 06:49:52 EDT
REVIEW: http://review.gluster.org/6043 (extras/hookscripts: Fix the multiple entries in smb.conf problem.) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 5 Anand Avati 2013-10-07 09:17:13 EDT
REVIEW: http://review.gluster.org/6043 (extras/hookscripts: Fix the multiple entries in smb.conf problem.) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 6 Anand Avati 2013-10-08 12:22:11 EDT
COMMIT: http://review.gluster.org/6043 committed in master by Anand Avati (avati@redhat.com) 
------
commit 11bb1fc5849a557d1a26e59bd651fbd0d07a1b8d
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Mon Oct 7 13:08:49 2013 +0530

    extras/hookscripts: Fix the multiple entries in smb.conf problem.
    
    Problem:
    1. Force starts and user.smb sets were adding multiple entries to
    the smb.conf file for the same volume.
    Make a check for the entry and search with exact name.
    
    2. Again, while deleting the share name from smb.conf search with
    exact name so that volumes with names which are substrings of ones to
    be deleted don't get deleted.
    
    3. We don't need to use a tmp file while using sed -i, fixed that.
    
    Change-Id: Ie0f7c9d4790ef9a177a043378a761c9ffe1628e5
    BUG: 994727
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/6043
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Lalatendu Mohanty <lmohanty@redhat.com>
    Tested-by: Lalatendu Mohanty <lmohanty@redhat.com>
Comment 7 Niels de Vos 2014-04-17 07:45:32 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.