Bug 994739 - qt4 rpm macros not found by rpm in F18
qt4 rpm macros not found by rpm in F18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 18:45 EDT by Christian Krause
Modified: 2013-08-10 16:05 EDT (History)
8 users (show)

See Also:
Fixed In Version: qt-4.8.5-6.fc18.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-10 16:05:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2013-08-07 18:45:30 EDT
Description of problem:
The latest qt-devel package places macros.qt4 into /usr/lib/rpm/macros.d

That won't work in F18, rpm does not search that directory.

Version-Release number of selected component (if applicable):
qt-devel-4.8.5-5.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. sudo yum install qt-devel
2. rpm --showrc |grep _qt4_qmake

Actual results:
- no output

Expected results:
- output like: "-14: _qt4_qmake	%{_qt4_bindir}/qmake"

Additional info:
Previous versions of qt.spec correctly checked the fedora version, but in commit b442626fe76a the check has been changed:

--- a/qt.spec
+++ b/qt.spec
@@ -13,11 +13,15 @@
 %define qt_settings 1
 %endif
 
-%define rpm_macros_dir %{_sysconfdir}/rpm
-%if 0%{?fedora} > 18
+%if 0%{?_rpmconfigdir:1}
 %define rpm_macros_dir %{_rpmconfigdir}/macros.d
+%else
+%define rpm_macros_dir %{_sysconfdir}/rpm
 %endif
 
This does not seem to work in F18, since the macro file is placed in /usr/lib/rpm/macros.d instead of /etc/rpm/. Because rpm does not search there, the _qt4* macros are not available (e.g. for rpmbuild).

Unfortunately, this causes problems when rebuilding packages...
Comment 1 Fedora Update System 2013-08-08 14:16:36 EDT
qt-4.8.5-6.fc18.1 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qt-4.8.5-6.fc18.1
Comment 2 Rex Dieter 2013-08-08 14:19:29 EDT
qt-4.8.5-6.fc18.1 is tagged for f18 buildroot override too, until it goes stable.
Comment 3 Fedora Update System 2013-08-09 13:14:41 EDT
Package qt-4.8.5-6.fc18.1:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.8.5-6.fc18.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14527/qt-4.8.5-6.fc18.1
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-10 16:05:35 EDT
qt-4.8.5-6.fc18.1 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.