Bug 994744 - Improve LogManager formatter capability: System properties, thread ID and minified category
Improve LogManager formatter capability: System properties, thread ID and min...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: EAP 6.3.0
Assigned To: James Perkins
Nikoleta Ziakova
Russell Dickenson
:
Depends On: 994700
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 19:42 EDT by Kyle Lape
Modified: 2014-10-25 08:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-16 14:08:13 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker LOGMGR-67 Major Resolved Improve LogManager formatter capability: System resources, thread ID and minified category 2014-09-09 05:05:37 EDT
JBoss Issue Tracker PRODMGT-413 Major Closed Improve formatter capability: System resources, thread ID and minified category 2014-09-09 05:05:37 EDT
JBoss Issue Tracker WFCORE-110 Minor Open Property expressions resolved before the PatternFormatter can resolve them 2014-09-16 14:08:13 EDT

  None (edit)
Description Kyle Lape 2013-08-07 19:42:35 EDT
This would include three things:

- Hostname: We haven't find a way to get the hostname displayed in the logs. A
  simple solution would be to include System properties and therefore the
  jboss.host.name property in the pattern.

- Thread ID: Thread names are too long and of different length that disturb the
  reading of logs

- Minified log categories: Logback has a feature that lets you minify the log
  category: instead of org.jboss.logmanager.config.ConfigAction you'll get
  o.j.l.c.ConfigAction which is more readable in the logs.

An implementation should match the formatting of the same feature in existing
logging frameworks to avoid end-user confusion.
Comment 1 JBoss JIRA Server 2013-09-03 23:38:04 EDT
James Perkins <jperkins@redhat.com> made a comment on jira LOGMGR-67

Pull request merged
Comment 6 Ondrej Lukas 2013-10-07 06:55:11 EDT
Unfortunatelly verification failed. Thread ID and Minified log categories are ok, but setting system property works bad. If I add %${test.property} to formatter and start server with -Dtest.property=property that use "p" from word property as %p and then log of that part looks like INFOroperty.
Comment 7 James Perkins 2013-10-07 12:59:18 EDT
Looks like the expression is attempting to be resolved by server instead of allowing the logmanager to resovle the expression.
Comment 10 James Perkins 2014-09-16 14:08:13 EDT
Closing this as it mostly works in the current release. The one caveat is the system properties do not work properly. The support has been added to the log manager, but the way that expressions are parsed for attributes the system property is resolved before the value is passed to the log manager. See https://issues.jboss.org/browse/WFCORE-110 for more details.

Note You need to log in before you can comment on or make changes to this bug.