Bug 994757 - Font for text objects reset to serif after reopening a new Impress presentation
Font for text objects reset to serif after reopening a new Impress presentation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-07 21:09 EDT by Steve
Modified: 2013-10-08 06:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: libreoffice-4.1.1.2-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 06:55:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 67665 None None None Never

  None (edit)
Description Steve 2013-08-07 21:09:55 EDT
Description of problem:

When adding text through the drawing tools to a slide, the default font used is usually a sans serif font.  After saving and reopening, the font of these text objects resets to serif. Note the font for the slide title and bullet-point list is not affected. Only text areas added from the drawing tools get reset to serif.

Version-Release number of selected component (if applicable):

libreoffice-impress-4.1.0.4-5.fc19.x86_64

How reproducible:

Always

Steps to Reproduce:
1.  Start a new impress document
2.  Type some text in the title and bullet point section
3.  Add a text area from the drawing tools
4.  Type some text in that as well (noting that it is sans serif font)
5.  Save, close, and open the file again.

Actual results:

Slide title and bullet point list are still in original sans serif font.  But added text is reset to serif.

Expected results:

Font settings in all text should be preserved, i.e. the text added should still be in sans serif font.

Additional info:

This affects text areas added in the master slide as well (for additional headers or footers).  

It would appear that opening the file the second time, changing the font back to sans serif, then saving makes the changes permanent.  So somehow, when starting up a new impress document, the default font for text areas is a serif font, even though this is not shown to the user.  The user sees it as sans serif.
Comment 1 Steve 2013-08-07 21:12:03 EDT
This problem affects old Impress documents created using previous versions of LibreOffice 3.  When opening up these documents the first time, the fonts are all fine (all sans serif).  But once a change is made and saved, the next time the file is reopened, all text areas have reset to serif.  This is very annoying since I have to manually change every single text area.
Comment 2 Caolan McNamara 2013-10-08 06:55:46 EDT
This should work in the now updated >= 4.1.1

Note You need to log in before you can comment on or make changes to this bug.