Bug 994785 - Unable to log in with the new user created in ldap mode
Unable to log in with the new user created in ldap mode
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Price
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-07 22:14 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:17:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ldap user authentication error (18.74 KB, image/png)
2013-08-07 22:15 EDT, sthirugn@redhat.com
no flags Details
production.log (19.67 KB, text/plain)
2013-08-07 22:30 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-08-07 22:14:00 EDT
Description of problem:
Unable to log in with the new user created in ldap mode

Version-Release number of selected component (if applicable):
* candlepin-0.8.19-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.19-1.el6sam.noarch
* candlepin-tomcat6-0.8.19-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-4.el6sat.noarch
* katello-cli-common-1.4.3-4.el6sat.noarch
* katello-common-1.4.3-5.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-5.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-5.el6sam_splice.noarch
* katello-headpin-1.4.3-5.el6sam_splice.noarch
* katello-headpin-all-1.4.3-5.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install SAM
2. Run katello-configure command in ldap - either in Active Directory or free_ipa mode
Active Directory mode:
katello-configure --deployment=sam --user-name=$user --user-email=$email --ldap-server=$ldapServer --auth-method=ldap --ldap-port=389 --ldap-server-type='active_directory' --ldap-users-basedn=$value --ldap-group-basedn=$value --ldap-roles=true --ldap-anon-queries=false --ldap-service-user=$serviceUser –ldap-service-pass=$servicePass --ldap-ad-domain=$domain
free ipa mode:
katello-configure --deployment=sam --user-name=$user --user-email=$email --ldap-server=$ldapServer --auth-method=ldap --ldap-port=389 --ldap-server-type='free_ipa' --ldap-users-basedn=$value --ldap-group-basedn=$value --ldap-roles=true --ldap-anon-queries=false --ldap-service-user=$serviceUser –ldap-service-pass=$servicePass --ldap-ad-domain=$domain
3. Log in to the Web UI as admin (configured in the above katello-configure commands) and add an other ldap user - say user1
4. Now try logging into sam using the newly created user - user1

Actual results:
Error screen appears (screenshot attached)

Expected results:
The new user is successfully logged in with the new user - user1

Additional info:
The same error is noticed in ldap - both Active Directory and free_ipa modes
Comment 1 sthirugn@redhat.com 2013-08-07 22:15:19 EDT
Created attachment 784191 [details]
ldap user authentication error
Comment 3 sthirugn@redhat.com 2013-08-07 22:30:40 EDT
Created attachment 784193 [details]
production.log

Added production.log which shows "can't convert nil into String " error
Comment 4 Adam Price 2013-09-05 18:00:26 EDT
https://github.com/Katello/katello/pull/2896
Comment 6 sthirugn@redhat.com 2013-09-12 16:09:28 EDT
Verified.

* candlepin-0.8.26-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.26-1.el6sam.noarch
* candlepin-tomcat6-0.8.26-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-10.el6sat.noarch
* katello-cli-common-1.4.3-10.el6sat.noarch
* katello-common-1.4.3-13.el6sam_splice.noarch
* katello-configure-1.4.4-4.el6sat.noarch
* katello-glue-candlepin-1.4.3-13.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-13.el6sam_splice.noarch
* katello-headpin-1.4.3-13.el6sam_splice.noarch
* katello-headpin-all-1.4.3-13.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 8 errata-xmlrpc 2013-10-01 07:17:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.