This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 994854 - Say that a machine with Secure Boot (UEFI) needs a 64 bit install
Say that a machine with Secure Boot (UEFI) needs a 64 bit install
Status: CLOSED UPSTREAM
Product: Fedora Documentation
Classification: Fedora
Component: fedora-websites (Show other bugs)
devel
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Websites Team
Fedora Websites Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 02:48 EDT by Matthew Cline
Modified: 2013-12-02 07:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 10:57:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Cline 2013-08-08 02:48:30 EDT
When I went first downloaded a "from the network" Fedora 19 installer ISO, I picked the 32 bit version.  It *seemed* to work fine, but because my machine has Secure Boot (UEFI) I couldn't boot; I had to download the 64 bit version and reinstall to fix things.  So in the places where the user has to select between 32 bit and 64 bit, "Secure Boot computers require 64 bit Linux" should be mentioned.  Also, it should be mention if a 32 bit computer is detected and the 32 bit version automatically offered, since someone might download and burn an install ISO on a 32 bit machine when intending to use it for a 64 bit machine.
Comment 1 Máirín Duffy 2013-08-08 10:57:28 EDT
Hi Matthew,

Thank you for your bug report. The Fedora websites team now uses the Trac ticketing system, so we've opened a ticket for this issue over there. 

In summary -

- We do not auto-detect arch and offer a download based on that. So you must have deliberately clicked on the 32 bit version.

- You are correct that 32-bit versions do not support UEFI because 32-bit hardware won't support UEFI - it's too old. 

- That being said, it seems reasonable to put a warning on the 32-bit version - since it's opt-in - that it is not compatible with UEFI hardware.

Here is the ticket. I'm closing this bug since the ticket will remain open to resolve the issue.

https://fedorahosted.org/fedora-websites/ticket/224
Comment 2 alan 2013-12-02 07:00:01 EST
> - You are correct that 32-bit versions do not support UEFI because 32-bit 
> hardware won't support UEFI - it's too old. 


No he's wrong. There are various 32bit UEFI platforms still being released with Windows 8 32bit. The Baytrail based tablet/convertibles for example.

Note You need to log in before you can comment on or make changes to this bug.