Bug 994868 - virt-viewer - unable to enter gnome-screensaver password
virt-viewer - unable to enter gnome-screensaver password
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-screensaver (Show other bugs)
6.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: ZStream
Depends On: 905935
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 03:13 EDT by Jan Kurik
Modified: 2013-08-27 06:58 EDT (History)
13 users (show)

See Also:
Fixed In Version: gnome-screensaver-2.28.3-24.el6.1
Doc Type: Bug Fix
Doc Text:
* Previously, when using virt-manager, virt-viewer, and spice-xpi applications, users were unable to enter the gnome-screensaver password after the screen saver started. This happened only when the VM system used the Compiz composting window manager. After users released the mouse cursor, then pressed a key to enter a password, the dialog did not accept any input. This happened due to incorrect assignment of window focus to applications that did not drop their keyboard grab. With this update, window focus is now properly assigned to the correct place, and attempts to enter the gnome-screensaver password no longer fail in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 06:58:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2013-08-08 03:13:51 EDT
This bug has been copied from bug #905935 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 7 errata-xmlrpc 2013-08-27 06:58:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1178.html

Note You need to log in before you can comment on or make changes to this bug.