Bug 994883 - Builds using latex2html gets stuck infinitely
Builds using latex2html gets stuck infinitely
Status: CLOSED DUPLICATE of bug 978233
Product: Fedora
Classification: Fedora
Component: latex2html (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 991957 992012
  Show dependency treegraph
 
Reported: 2013-08-08 03:59 EDT by Simone Caronni
Modified: 2013-09-05 12:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 12:28:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simone Caronni 2013-08-08 03:59:22 EDT
Description of problem:
bacula-docs package in Fedora 20. Build was stuck for 15 hours and then killed by Koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5698742

I was able to reproduce it locally with mock; all the "latex2html" commands get stuck indefinitely. An example command from the Koji build:

make[1]: Entering directory `/builddir/build/BUILD/bacula-docs-5.2.13/manuals/en/developers'
[...]
latex2html -split 4 -local_icons -t "Developer's Guide" -long_titles 4 \
-toc_stars -contents_in_nav -init_file latex2html-init.pl \
-no_antialias -no_antialias_text \
-white -notransparent developers >tex.out 2>&1
make[1]: *** [web] Error 1


If I look into the tex.out log file I can see that the command gets stuck creating an infinite line of dots. Example:


$ tail 2 tex.out | less
==> tex.out <==
;...;..

120/213:subsection:...."Minimal Code in Console Program" for General.html
;..;...

121/213:subsection:...."GUI Interface is Difficult" for General.html
;..,....,....,...;...........
...
122/213:section:...."Bvfs API" for Bvfs_API.html
;...,.................................................. [...]

The moment I stopped my mock build that was running for 3 minutes I already had an 18 mb file; 90% of it filled with dots in the last line.

Version-Release number of selected component (if applicable):
latex2html-2012-4.fc20

How reproducible:
Always.

Steps to Reproduce:
1. Try to do a scratch build of bacula-docs in rawhide

Actual results:
Builds gets stuck until Koji kills it. Current stuck build at the moment of writing:

https://koji.fedoraproject.org/koji/taskinfo?taskID=5792896

Expected results:
Build should succeed as the latest build that was done in April.
Comment 1 Jan Kaluža 2013-08-08 08:36:15 EDT
I have the same problem while building adevs package in rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=5794017
Comment 2 Jaroslav Škarvada 2013-09-05 12:28:42 EDT
It is regression in perl-5.18, closing as dupe of bug 978233.

*** This bug has been marked as a duplicate of bug 978233 ***

Note You need to log in before you can comment on or make changes to this bug.