Bug 994944 - spacewalk-report crashes with traceback on multival columns
spacewalk-report crashes with traceback on multival columns
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Jiří Mikulka
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-08-08 05:36 EDT by Jiří Mikulka
Modified: 2014-10-06 09:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-reports-2.0.1-4-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:50:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Mikulka 2013-08-08 05:36:23 EDT
Description of problem:
spacewalk-report is trying to sort multival columns so reports are consistent. But when trying to sort (so far) empty multival column it fails with traceback:

Traceback (most recent call last):
  File "/usr/bin/spacewalk-report", line 247, in ?
    outrow[m] = options.multivalseparator.join(sorted(outrow[m].split(options.multivalseparator)))
AttributeError: 'NoneType' object has no attribute 'split'

Version-Release number of selected component (if applicable):
spacewalk-reports-2.0.1-3.el5sat

How reproducible:
always on report which might have multival column

Steps to Reproduce:
1. create user with more than 1 role
2. run spacewalk-report users
3. see the output

Actual results:
Traceback (most recent call last):
  File "/usr/bin/spacewalk-report", line 247, in ?
    outrow[m] = options.multivalseparator.join(sorted(outrow[m].split(options.multivalseparator)))
AttributeError: 'NoneType' object has no attribute 'split'

Expected results:
users info are shown correctly

Additional info:
Comment 4 Clifford Perry 2013-10-01 17:50:07 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.