Bug 994950 - quota: Input/output error while reaching to fill already set quota limit
quota: Input/output error while reaching to fill already set quota limit
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
2.1
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Susant Kumar Palai
Saurabh
: ZStream
Depends On:
Blocks: 1020127
  Show dependency treegraph
 
Reported: 2013-08-08 05:45 EDT by Saurabh
Modified: 2016-09-17 08:43 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
An input-output error is seen instead of the Disk quota exceeded error when the quota limit exceeds. This issue is fixed in the Red Hat Enterprise Linux 6.5 Kernel.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-12 05:29:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-08-08 05:45:29 EDT
Description of problem:
This kind of bug was already filed as 981553, I see that issue is not seen for fuse mount
still I can see the problem over nfs mount.

getting I/O error over nfs mount.

Version-Release number of selected component (if applicable):
[root@nfs1 ~]# rpm -qa | grep glusterfs
glusterfs-api-3.4.0.17rhs-1.el6rhs.x86_64
glusterfs-3.4.0.17rhs-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.17rhs-1.el6rhs.x86_64
glusterfs-libs-3.4.0.17rhs-1.el6rhs.x86_64
samba-glusterfs-3.6.9-156.2.el6rhs.x86_64
glusterfs-fuse-3.4.0.17rhs-1.el6rhs.x86_64
glusterfs-server-3.4.0.17rhs-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.17rhs-1.el6rhs.x86_64

How reproducible:
happened on this build also.

Steps to Reproduce:
1. create a volume as 6x2, start it.
2. enable quota on the volume
3. put a limit of 2GB
4. mount the volume nfs
5. create a directory inside the volume
6. put a limit of 1GB on the directory
7. start creating data inside the dir

Actual results:
dd: closing output file `10151375924011': Input/output error
dd: closing output file `10161375924011': Input/output error
dd: closing output file `10171375924011': Disk quota exceeded
dd: closing output file `10181375924012': Input/output error
dd: closing output file `10191375924012': Disk quota exceeded
dd: closing output file `10201375924012': Input/output error
dd: closing output file `10211375924012': Input/output error
dd: closing output file `10221375924013': Input/output error
dd: closing output file `10231375924013': Input/output error
dd: closing output file `10241375924013': Input/output error
dd: closing output file `10251375924013': Input/output error
dd: closing output file `10261375924014': Input/output error
dd: opening `10271375924014': Disk quota exceeded
dd: opening `10281375924014': Disk quota exceeded
dd: opening `10291375924014': Disk quota exceeded
dd: opening `10301375924014': Disk quota exceeded
[root@rhsauto030 dir]# dd if=/dev/urandom of=newfile bs=1024 count=1024
dd: opening `newfile': Disk quota exceeded

Expected results:
there should not be any I/O error

Additional info:
Comment 5 Pavithra 2013-10-28 00:41:40 EDT
Pranith,

Can you please review the doc text?
Comment 6 Vivek Agarwal 2013-11-14 06:27:33 EST
Moving the known issues to Doc team, to be documented in release notes for U1
Comment 7 Vivek Agarwal 2013-11-14 06:29:23 EST
Moving the known issues to Doc team, to be documented in release notes for U1
Comment 8 Vivek Agarwal 2013-11-14 06:29:59 EST
Moving the known issues to Doc team, to be documented in release notes for U1
Comment 11 Vijaikumar Mallikarjuna 2015-01-12 05:29:18 EST
The issue is with NFS client and not with quota. It has been fixed in RHEL-6.5.
Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.