Bug 99496 - kernel.spec no longer supports --with/--without
kernel.spec no longer supports --with/--without
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 99497 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-21 08:10 EDT by Keith Owens
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-07 19:02:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Owens 2003-07-21 08:10:51 EDT
From Bugzilla Helper:
User-Agent: Opera/7.10 (Linux 2.4.21-xfs i686; U)  [en]

Description of problem:
RH 9 deleted these lines from kernel.spec

# allow --with[out] <feature|kernel> at rpm command line build
# e.g. --with smp --without smp --without BOOT --without bigmem --with  ibcs
# --with overrides --without
%{?_without_up: %{expand: %%define buildup 0}}
%{?_without_smp: %{expand: %%define buildsmp 0}}
%{?_without_BOOT: %{expand: %%define buildBOOT 0}}
...

so rpmbuild ignores --with/--without on the command line when building 
the kernel.

The lines were in RH 8 (kernel-2.4.18-14.src.rpm), they are also
missing from the latest RH 7, 8 and 9 errata kernel.spec files
(kernel-2.4.20-18.[789].src.rpm).

There is nothing in the changelog about removing this facility and the
kernel.spec comments still say that --with/--without can be used.

On the same subject, what do these lines do?  Nothing seems to test
the defined macros.

# we can't test values inline, only whether a macro exists
%{expand: %%define buildup_%{buildup} yadda}
%{expand: %%define buildsmp_%{buildsmp} yadda}

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -ba --without smp kernel-2.4.spec
2. 
3.
    

Actual Results:  --without smp ignored on rh 9 and recent rh [78] errata 
kernels.

Expected Results:  Build without any of the SMP kernels.

Additional info:
Comment 1 Michael K. Johnson 2003-08-07 18:46:30 EDT
*** Bug 99497 has been marked as a duplicate of this bug. ***
Comment 2 Michael K. Johnson 2003-08-07 19:02:10 EDT
We removed the --with/out bits because they were too little value for
the amount of verbage that got in the way near the top of the spec file.
Also, it was easily possible to specify nonsensical combinations, and
the feature definitions weren't necessarily kept up, which lead to more
bug reports.

Instead, just edit the appropriate define in the spec file, exchanging
0's and 1's as appropriate.

All the leftover cruft you notice is gone in our current source tree.

So part of this is "NOTABUG", another is "RAWHIDE"; I'll close RAWHIDE
as the best alternative.

Note You need to log in before you can comment on or make changes to this bug.