Bug 995000 - Recurring events are not detected and cause never-ending job
Recurring events are not detected and cause never-ending job
Status: CLOSED DUPLICATE of bug 954219
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.14
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 07:37 EDT by Marian Ganisin
Modified: 2014-08-12 00:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 17:57:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Ganisin 2013-08-08 07:37:55 EDT
Description of problem:
Typically during first task (which is most often /distribution/install) some issue may occur that causes that the process is restarted (it can be hardware issue, incorrect boot order setup after installation or whatever). Such jobs can be identified for example by reporting one event/subtask repeatedly, for example:

/distribution/install
  	  ./start
  	  ./start
  	  ./start
  	  ./start
  	  ./start
  	  ./start
  	  ./start
  	  ./start
  	  ./start
...

This causes infinite loop and never-ending job. This seems to be easy to detect and job can be aborted in case of loop.

Version-Release number of selected component (if applicable):
Version - 0.14.1

How reproducible:
unclear conditions

Actual results:
Never-ending job stuck in a loop

Expected results:
Recurring event detected, job aborted

Note You need to log in before you can comment on or make changes to this bug.