Bug 995012 - Track job activity
Track job activity
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.14
Unspecified Unspecified
high Severity high (vote)
: 0.17
: ---
Assigned To: matt jia
tools-bugs
: FutureFeature
Depends On:
Blocks: 651479 798710
  Show dependency treegraph
 
Reported: 2013-08-08 08:05 EDT by Ales Zelinka
Modified: 2014-06-10 19:28 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-10 19:28:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2013-08-08 08:05:41 EDT
Job History should contain record for any change done to a job by a user (and possibly by beaker itself). At least these should be logged:

 * cancellation
 * ack/nack
 * retention tag change
 * priority change


It's crucial to be able to trace changes back to the user who did them when more than one user can manipulate the jobs (submission delegates).
Comment 2 Nick Coghlan 2013-08-10 15:52:34 EDT
This is relevant for group jobs as well, since any group member may update the items Ales mentions.
Comment 3 xjia 2013-08-11 19:48:19 EDT
(In reply to Nick Coghlan from comment #2)
Is it a future feature?
Comment 4 Nick Coghlan 2013-08-25 21:40:01 EDT
This actually affects the old implicit job sharing model as well - even prior to explicit group jobs and submission delegates, multiple users could still update a job, without a clear history of who did what and when.
Comment 5 Nick Coghlan 2013-10-09 01:28:44 EDT
Definitely need to include this in 0.16, since http://beaker-project.org/dev/proposals/improved-reservations-and-loans.html#time-limited-loans will lead to the scheduler cancelling jobs automatically and users need to be able to see what happened.
Comment 7 matt jia 2014-05-05 01:45:16 EDT
On Gerrit:
 
http://gerrit.beaker-project.org/#/c/3059/

Cheers, Matt Jia
Comment 10 Dan Callaghan 2014-06-10 19:28:02 EDT
Beaker 0.17.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.