Bug 995027 - "Field type" not displayed when editting properties of fields of some types
"Field type" not displayed when editting properties of fields of some types
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity low
: ER3
: 6.0.0
Assigned To: Pere Fernàndez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 08:29 EDT by Jan Hrcek
Modified: 2014-08-06 16:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hrcek 2013-08-08 08:29:58 EDT
Description of problem:
When editting field properties (by clicking on Edit - pencil icon for a field) the field type does not display anything for the following 4 field types:

-HTML label
-separator
-Simple subform
-Multiple subform

Version-Release number of selected component (if applicable):
6.0.0.CR1

How reproducible:
Always in my environment (the same issue in Firefox 22 & Google chrome 28)

Steps to Reproduce:
1. Open business central - go to some project and create a new form
2. Go to 'Add fields by type' and add 1 field of each type to the canvas
3. For the 4 fields mentioned above click the 'Edit' button to go to field properties side widnow


Actual results:
The field type is not displayed for the 4 field types mentioned (see screenshot)

Expected results:
Either the 'Field type' label should be removed for these 4 field types, or the type should be displayed. The 2nd option would  be preferable for consistency.
Comment 1 Pere Fernàndez 2013-08-12 11:27:45 EDT
The field type combo wasn't rendering for decorator types (HTMLLabel & Separator)  since they aren't persistible types.

On subform (simple & multiple) it wasn't working because an error loading this field types on FieldTypeManagerImpl.

Commit:
https://github.com/droolsjbpm/jbpm-form-modeler/commit/126df6307fd29c4cb4b9510cd756cba17b635787
Comment 2 Jan Hrcek 2013-09-02 03:40:55 EDT
The problem is still present in ER2. I checked the 6.0.x branch on github and it seems that the above mentioned fix was only commited to master branch. Please add it to 6.0.x product branch as well.
Comment 3 Pere Fernàndez 2013-09-02 09:16:33 EDT
Done, sorry.
Comment 4 Jan Hrcek 2013-09-23 02:54:29 EDT
Verified with BPMS 6.0.0 ER3

Note You need to log in before you can comment on or make changes to this bug.