Bug 995047 - Bluetooth mouse randomly disconnects
Bluetooth mouse randomly disconnects
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 09:08 EDT by Rafael Ávila de Espíndola
Modified: 2013-09-25 15:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 12:52:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Ávila de Espíndola 2013-08-08 09:08:11 EDT
Description of problem:

My mouse disconnects from time to time (and reconnects after a minute or so). This is very similar to the ubuntu bug:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1072234

I am setting component to kernel based on the discussion on that bug.

Version-Release number of selected component (if applicable):

Version     : 3.10.4
Release     : 300.fc19
Architecture: x86_64

How reproducible:

always.

Steps to Reproduce:
1. pair a bluetooth mouse
2. wait
3.
Comment 1 Rafael Ávila de Espíndola 2013-08-08 09:09:52 EDT
in dmesg I found:

[ 2217.008082] magicmouse 0005:05AC:030D.0009: unknown main item tag 0x0
[ 2222.012662] input: espindola’s Mouse as /devices/pci0000:00/0000:00:1a.7/usb1/1-1/1-1.1/1-1.1.1/1-1.1.1:1.0/bluetooth/hci0/hci0:11/input16
[ 2222.014243] magicmouse 0005:05AC:030D.0009: input,hidraw0: BLUETOOTH HID v3.06 Mouse [espindola’s Mouse] on 64:b9:e8:d8:06:05
[ 2828.175855] magicmouse 0005:05AC:030D.000A: unknown main item tag 0x0
[ 2833.181281] input: espindola’s Mouse as /devices/pci0000:00/0000:00:1a.7/usb1/1-1/1-1.1/1-1.1.1/1-1.1.1:1.0/bluetooth/hci0/hci0:13/input17
[ 2833.182800] magicmouse 0005:05AC:030D.000A: input,hidraw0: BLUETOOTH HID v3.06 Mouse [espindola’s Mouse] on 64:b9:e8:d8:06:05
Comment 2 Josh Boyer 2013-09-18 16:32:17 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 Rafael Ávila de Espíndola 2013-09-25 12:35:45 EDT
It does look a lot more reliable now. Thanks!
Comment 4 Josh Boyer 2013-09-25 12:52:49 EDT
THanks.
Comment 5 Rafael Ávila de Espíndola 2013-09-25 15:05:07 EDT
I spoke too soon, the mouse just disconnected and reconnected again :-(

It was connected most of Yesterday and seems to have reconnected faster than usual today, so things are probably better, but I still got the same dmesg log as in command 1.

Note You need to log in before you can comment on or make changes to this bug.