Bug 995059 - GTK3 - Crash when moving window on Windows XP
GTK3 - Crash when moving window on Windows XP
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mingw-pixman (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 09:30 EDT by Mikkel Kruse Johnsen
Modified: 2013-09-22 20:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: mingw-pixman-0.30.0-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-14 20:51:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikkel Kruse Johnsen 2013-08-08 09:30:58 EDT
Description of problem:
On some Windows XP machines a Gtk3 app crashes when a window is moved (Maximize/Minimize is working).

I get a "C++ Runetime Error".

I'm not sure if Gtk3 need "C++ Redistributable Package". If it has something to do with that version ?


Version-Release number of selected component (if applicable):
mingw32-gtk3-3.8.2-2.fc19.noarch


How reproducible:
Start a Gtk3 program and move a window.

Steps to Reproduce:
1. Start App
2. Move Window

Actual results:
Crash


Expected results:
Window is moved


Additional info:
Comment 1 Erik van Pienbroek 2013-08-10 08:18:06 EDT
Could you try to compile your executable with the '-mconsole' flag? This causes your executable to show a console window when it is executed (or you can executable it directly from cmd.exe). I would expect that in this situation it will show additional information in the console window when the runtime error occurs.

Otherwise you'd have to use WinDBG and change its settings so that it breaks on abort() calls (gdb can't catch this for some reason)
Comment 2 Mikkel Kruse Johnsen 2013-08-16 09:51:09 EDT
I have tried to compile the gtk3-demo.exe with '-mconsole' with no luck.

It happens also on the "gtk3-widget-factory.exe" when moved rapidly around, if someone else could try.

(Only on Windows XP)
Comment 3 Mikkel Kruse Johnsen 2013-08-19 05:03:32 EDT
https://mail.gnome.org/archives/gtk-app-devel-list/2012-July/msg00067.html

Just found this. I'm not sure if that is in Gtk3. A lot have changed in gdkevents-win32.c since Gtk2.

It can be reproduced by this:

1)  Launch any gtk-win32 app
2)  Right-click the application's title bar and select 'Move'
3)  Without clicking your mouse yet, move the mouse, then left-click it, anywhere outside of the app
4)  Right-click the title bar again and your app will crash
Comment 4 Mikkel Kruse Johnsen 2013-08-19 07:25:07 EDT
I recompiled pixman 0.30.2 with "--disable-sse2" and it now works on Windows XP.
Comment 5 Mikkel Kruse Johnsen 2013-08-19 07:56:58 EDT
Crash dump here:

http://www.marshut.com/qivmr/pixman-run-time-error.html
Comment 6 Michael Cronenworth 2013-08-19 17:36:28 EDT
Have you reported this upstream?

https://bugs.freedesktop.org/enter_bug.cgi?product=pixman
Comment 7 Mikkel Kruse Johnsen 2013-08-20 01:40:18 EDT
https://bugs.freedesktop.org/show_bug.cgi?id=68300
Comment 8 Kalev Lember 2013-09-04 14:57:18 EDT
Thanks for tracking it down. I've built new pixman packages with sse2 disabled, hope this helps.
Comment 9 Fedora Update System 2013-09-04 14:57:53 EDT
mingw-pixman-0.30.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mingw-pixman-0.30.0-3.fc19
Comment 10 Fedora Update System 2013-09-04 14:58:20 EDT
mingw-pixman-0.30.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mingw-pixman-0.30.0-4.fc20
Comment 11 Fedora Update System 2013-09-05 13:52:53 EDT
Package mingw-pixman-0.30.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mingw-pixman-0.30.0-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15856/mingw-pixman-0.30.0-4.fc20
then log in and leave karma (feedback).
Comment 12 Nicola Fontana 2013-09-06 16:56:05 EDT
Disabled sse2 optimization in pixman on my handcrafted mingw GTK+3 toolchain: all is working fine. Many thanks for solving this long-standing issue.
Comment 13 Fedora Update System 2013-09-14 20:51:32 EDT
mingw-pixman-0.30.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-09-22 20:26:20 EDT
mingw-pixman-0.30.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.