Bug 995111 - Column names in an export of an enhanced report (splice_reports) need to be updated to match webui.
Column names in an export of an enhanced report (splice_reports) need to be u...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: Splice Developers
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-08 10:45 EDT by John Matthews
Modified: 2013-10-01 07:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:17:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2013-08-08 10:45:33 EDT
Description of problem:

When performing an 'export' of an enhanced report the column names are not lining up to the displayed text in the webui.

Example:
 "checkin_date" instead of "CHECKIN-IN TIME"
 "identifier" instead of "SYSTEM ID"
 "splice_server" instead of "SATELLITE SERVER"
 ... 


Steps to Reproduce:
1. Create a filter
2. Select 'Export'
3. Open export and look at export.csv
4. Examine first row which has the header values

Actual results:
_id, record, checkin_date, status, identifier, splice_server, systemid, hostname, organization_name, state

Expected results:

_id, record, CHECK-IN TIME, STATUS, SYSTEM ID, SATELLITE SERVER, SYSTEM ID, HOSTNAME, ORGANIZATION, LIFECYCLE STATE, 


Additional info:
Comment 1 John Matthews 2013-08-08 10:48:40 EDT
Fixed in:

https://github.com/splice/splice-reports/commit/2dcb07d8afdab703a0eb9a77eb31c72a91cd59f4

Will be in:
rubygem-splice_reports-0.0.5-39-sat
Comment 3 Vitaly Kuznetsov 2013-08-21 10:35:08 EDT
% head -1 export.csv 
_id, record, CHECK-IN TIME, STATUS, SYSTEM ID, SATELLITE SERVER, SYSTEM ID, HOSTNAME, ORGANIZATION, LIFECYCLE STATE,

We meet "SYSTEM ID" field twice and it means different things: katello id and satellite id. Was it supposed to be this way?
Comment 4 John Matthews 2013-08-21 10:59:58 EDT
Changed an extra header field of "SYSTEM ID" to "DB ID", this corresponds to the mongodb id of the original record the aggregation query returned.


https://github.com/splice/splice-reports/commit/ba04ad857cae0605efb73dd82aba68094a3b1220
Comment 5 Bryan Kearney 2013-08-28 13:11:58 EDT
Lates build (Snap4) should contain these fixes. Please test on Snap4.
Comment 6 Vitaly Kuznetsov 2013-09-13 05:26:30 EDT
Verified with Snapshot 6

% head -1 export.csv 
_id, record, CHECK-IN TIME, STATUS, DB ID, SATELLITE SERVER, SYSTEM ID, HOSTNAME, ORGANIZATION, LIFECYCLE STATE,
Comment 8 errata-xmlrpc 2013-10-01 07:17:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.