Bug 995118 - [RFE] Some mandatory fields are not highlighted in reports new filter menu
[RFE] Some mandatory fields are not highlighted in reports new filter menu
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Splice Developers
mkovacik
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 10:57 EDT by Pavlina Bartikova
Modified: 2013-10-01 07:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:17:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sam screenshot (53.98 KB, image/png)
2013-08-09 06:57 EDT, Pavlina Bartikova
no flags Details

  None (edit)
Description Pavlina Bartikova 2013-08-08 10:57:26 EDT
Description of problem:
When adding a new filter in reports, some mandatory fields are not highlighted (LifeCycle State, Search by).

How reproducible:
Always.

Steps to Reproduce:
1. Administer -> Reports
2. +NewFilter

Actual results:
Mandatory fields should be highlighted (only Name and Subscription Status are).

Expected results:
Some mandatory fields are not highlighted.

Additional info:
Comment 1 Chris Duryee 2013-08-08 14:48:29 EDT
Pavlina,

Can you attach a screenshot? I don't see any highlighted fields on my machine.
Comment 2 Pavlina Bartikova 2013-08-09 06:57:18 EDT
Created attachment 784793 [details]
sam screenshot

"Name" and "Subscription Status" are highlighted (boldface). The other majority fields should be highlighted too.

(I'm using SAM-1.3.0-RHEL-6-20130805.0-SAM-x86_64-dvd1.iso)
Comment 3 Chris Duryee 2013-08-14 12:18:02 EDT
Pavlina,

This is somewhat related to #995132. In #995132, there were multiple validators for a couple of fields, which resulting in multiple messages being printed. I removed the extraneous validators, but this caused the bolding for all fields to disappear as well.

Is this ok to leave all fields without bold text? I think it is ok since some of the fields are either/or, and do not benefit from being bolded (example: the radio buttons)

marking as MODIFIED since #995132 is modified.
Comment 4 Pavlina Bartikova 2013-08-21 09:26:37 EDT
Confirmed. All fields are without bold text.

Moving bug to VERIFIED.
Comment 6 errata-xmlrpc 2013-10-01 07:17:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.