Bug 995132 - [RFE] No difference between name error messages in reports new filter menu
[RFE] No difference between name error messages in reports new filter menu
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Duryee
mkovacik
: FutureFeature
Depends On:
Blocks: sam13-tracker 1002114
  Show dependency treegraph
 
Reported: 2013-08-08 11:25 EDT by Pavlina Bartikova
Modified: 2013-10-01 07:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1002114 (view as bug list)
Environment:
Last Closed: 2013-10-01 07:17:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavlina Bartikova 2013-08-08 11:25:50 EDT
Description of problem:
When adding a new filter in reports, there are two error messages for empty name field

How reproducible:
Always.

Steps to Reproduce:
1. Administer -> Reports
2. +NewFilter
3. confirm with empty name field

Actual results:
Error messages "Name can't be blank" and "Name must contain at least 1 character"

Expected results:
Only one of these messages.

Additional info:
Comment 1 Pavlina Bartikova 2013-08-08 11:32:44 EDT
It would be much better for QA testing, if the error messages didn't contain single quotes (Name can't be blank -> Name can not be blank).
Comment 2 Pavlina Bartikova 2013-08-08 12:31:56 EDT
The same problem is with Subscription status, messages "Status can't be blank" and "Please select at least one Subscription Status."
and with hour and date criteria, messages "Please choose either a date range or number of hours" and "Both the hour and date criteria of the filter are blank".
Comment 3 Chris Duryee 2013-08-08 14:43:09 EDT
ff2abe5 splice-reports 0.0.5-40
Comment 4 Chris Duryee 2013-08-08 14:44:25 EDT
Pavlina,

I fixed the majority of the issues, but left the "please choose a date range or number of hours" and "both the hour and date criteria of the filter are blank" errors, since they refer to different fields (radio button vs text field).
Comment 5 Pavlina Bartikova 2013-08-21 09:29:53 EDT
Confirmed.

Moving bug to VERIFIED.
Comment 6 Pavlina Bartikova 2013-08-21 11:24:52 EDT
There is no difference between "Please choose either a date range or number of hours" and "Both the hour and date criteria of the filter are blank" messages.

Moving bug back to ASSIGNED.
Comment 8 Pavlina Bartikova 2013-08-28 09:49:59 EDT
Bug was cloned for SAM 1.4, https://bugzilla.redhat.com/show_bug.cgi?id=1002114.

Moving to VERIFIED.
Comment 10 errata-xmlrpc 2013-10-01 07:17:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.