Bug 995142 - DHCP FAIL $reason removes source routing configuration on management network
DHCP FAIL $reason removes source routing configuration on management network
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
high Severity high
: ---
: 3.3.0
Assigned To: Assaf Muller
Martin Pavlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 12:05 EDT by Assaf Muller
Modified: 2016-02-10 14:57 EST (History)
10 users (show)

See Also:
Fixed In Version: is10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:30:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amuller: needinfo-


Attachments (Terms of Use)
logs from /var/log/messages and /var/log/supervdsm (3.38 KB, text/plain)
2013-08-08 12:05 EDT, Assaf Muller
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17961 None None None Never
oVirt gerrit 17963 None None None Never

  None (edit)
Description Assaf Muller 2013-08-08 12:05:04 EDT
Description of problem:
ntpd is getting signal 15, which sends DHCP FAIL, which is activating the DHCP sourceRoute.sh script with a DHCP remove statement, thus removing source routing on the management network, and only the management network.

Version-Release number of selected component (if applicable):
VDSM master - vdsm-4.12.0-44.git94918e0.el6.x86_64

Reason is unknown - It is happening a lot on a host of mine though so it is not a problem to reproduce, I just don't know how.

It is unknown why ntpd is sending dhcp reason FAIL, and unknown why it's only sending it to the ovirtmgmt interface and not other active dhcp interfaces.
Comment 1 Assaf Muller 2013-08-08 12:05:58 EDT
Created attachment 784474 [details]
logs from /var/log/messages and /var/log/supervdsm
Comment 2 Assaf Muller 2013-08-12 07:37:36 EDT
This started happening on my hosts a few days ago.
This also happens if dhclient itself sends FAIL to its hooks:

Aug 12 14:35:25 zeus02 dhclient[14632]: send_packet: No such device or address
Aug 12 14:35:26 zeus02 dhclient[14632]: No DHCPOFFERS received.
Aug 12 14:35:26 zeus02 dhclient[14632]: No working leases in persistent database - sleeping.
Aug 12 14:35:26 zeus02 root: sourceRoute_restore called because FAIL

I inserted the last line into the dhcp hook momentarily - You can see the reason is FAIL.
Comment 3 Martin Pavlik 2013-08-14 09:49:05 EDT
Assaf, can you please elaborate on how to test?

I had source routing configured on the host, I've assigned VLAN with tag 1 to one host interface and had it configured with DHCP. Host does not have access to this VLAN so DHCP request for IP failed. Source routing was intact. Is this how it is supposed to work?
Comment 4 Assaf Muller 2013-08-25 04:57:14 EDT
If you had an IP and source routing configured then a failed DHCP request doesn't remove the ip configuration from the device and thus should not remove source routing.

The goal of the fix is that only if the ip configuration is removed then source routing should be removed.

Sadly I don't know how to reproduce the bug. You can manually send a DHCP fail to test that source routing is not removed, but sending DHCP stop (Like what ifdown does) does.
Comment 5 Charlie 2013-11-27 19:30:00 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:30:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.