Bug 995164 - JBoss component master pom references incorrect version of jackson-mapper-asl
JBoss component master pom references incorrect version of jackson-mapper-asl
Status: CLOSED DUPLICATE of bug 1037676
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Gier
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 12:56 EDT by Kyle Lape
Modified: 2014-07-02 17:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 17:53:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle Lape 2013-08-08 12:56:41 EDT
If I try to add a dependency to my pom.xml like:

   <dependency>
     <groupId>org.codehaus.jackson</groupId>
     <artifactId>jackson-mapper-asl</artifactId>
     <version>1.9.9-redhat-2</version>
     <scope>provided</scope>
   </dependency>

I get an error:

[ERROR] Failed to execute goal on project my-project: Could not resolve dependencies for project com.redhat.gss:my-project:jar:1.1-SNAPSHOT: Failure to find org.codehaus.jackson:jackson-core-asl:jar:1.9.9-redhat-1 in file:/path/to/jboss-eap-6.1.0.GA-maven-repository was cached in the local repository, resolution will not be reattempted until the update interval of jboss-eap-repository has elapsed or updates are forced -> [Help 1]

Notice how the error mentions version 1.9.9-redhat-1, which is not what I specified.  This is due to the JBoss component master pom referencing an incorrect version of jackson-mapper-asl.
Comment 1 Paul Gier 2014-07-02 17:53:10 EDT
Closing this as a duplicate of bug 1037676.  We should be able to fix this for 6.4.

*** This bug has been marked as a duplicate of bug 1037676 ***

Note You need to log in before you can comment on or make changes to this bug.