Bug 995179 - iptables no longer has a useful manpage, describing all modules and their targets
iptables no longer has a useful manpage, describing all modules and their tar...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 13:37 EDT by Samium Gromoff
Modified: 2013-11-25 07:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 07:35:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samium Gromoff 2013-08-08 13:37:33 EDT
iptables does not have a useful manpage, describing all modules and their targets.

See, for example, the corresponding Debian package.

iptables package version 1.4.18
Comment 1 Quentin Armitage 2013-11-23 16:29:59 EST
Use man iptables-extensions. This is described in the iptables man page.
Comment 2 Samium Gromoff 2013-11-24 10:16:25 EST
Alright, sorry for the noise then, I feel like this bug can be closed.

It'd be lovely, though, if the "go to iptables-extensions manpage for
the usual stuff" was noted more prominently.

The reason I'm suggesting this is stemming from how I came to miss these
actually not-that-obscure references.

When you use a certain utility for a _long_ time, you learn its
documentation ins and outs -- and you switch from the "parse the
document" mode to a "grep the document for well-known keywords" mode.

And the grep thing totally failed me, indeed.

So, I think, a bigger, louder "the structure of this document has
changed in significant ways" disclaimer at the start of the manpage
would be helpful for lost souls like me..
Comment 3 Thomas Woerner 2013-11-25 07:35:41 EST
Closing as "NOT A BUG".

BTW: iptables-extensions is referenced in "MATCH AND TARGET EXTENSIONS" and also in "SEE ALSO".

Note You need to log in before you can comment on or make changes to this bug.