Bug 99522 - iomega zip 100 (parallel) fails to mount /dev/sda
iomega zip 100 (parallel) fails to mount /dev/sda
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-21 11:34 EDT by Lucas Jordan
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lucas Jordan 2003-07-21 11:34:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
to mount an iomega 100 parallel drive one should only have to type (as su)

mount -t vfat /dev/sda [taget dir]

or one can first manually load the correct modules (to help the kernel?)

as root:
/sbin/insmod imm    (in my case)
or 
/sbin/insmod ppa     (for other devices?)

some documentation (http://www.tldp.org/HOWTO/mini/ZIP-Drive.html)
suggest unloading the module lp befor loading ppa and perhaps befor loading imm.

in any case, 
dmesg reports:

imm: Version 2.05 (for Linux 2.4.0)
imm: Found device at ID 6, Attempting to use EPP 32 bit
imm: Found device at ID 6, Attempting to use SPP
imm: Communication established at 0x378 with ID 6 using SPP
scsi1 : Iomega VPI2 (imm) interface
  Vendor: IOMEGA    Model: ZIP 100           Rev: J.67
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 6, lun 0
scsi: device set offline - not ready or command retry failed after bus reset:
host 1 channel 0 id 6
lun 0
SCSI device sda: 196608 512-byte hdwr sectors (101 MB)
sda: Write Protect is off
 sda: I/O error: dev 08:00, sector 0
 I/O error: dev 08:00, sector 0
 unable to read partition table


which results in, iomega zip 100 (parallel) failing to mount /dev/sda
reporting:
mount -t vfat /dev/sda /mnt/zip/
mount: /dev/sda is not a valid block device



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.try to mount an iomega 100 zip (parallel) drive with redhat 9 (see description)
2.
3.
    

Actual Results:  mount: /dev/sda is not a valid block device

Expected Results:  the drive should be mounted .

Additional info:

i have alos tried to use IOMega's own program for mounting disks, it fails as
well, with whay looks like the same problem, just worded differently:

#./iw -i /dev/sda
 
 
IomegaWare for Linux Release 1.0 09/13/00
Failure accessing  DEVICE: '/dev/sda'
Comment 1 chrisw 2003-08-20 16:57:57 EDT
if you are running the latest kernel,
upgrade to the latest kernel reboot and try again
to mount the zip disk...i had this same problem..
i dont remember what kernel i was runnning at the time
but after i updated to the latest...everything worked fine

mount the drive as follows
mount /dev/sda4 -t vfat /mnt/zip

Comment 2 Bugzilla owner 2004-09-30 11:41:19 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.