Bug 995239 - able to log in without an org selected
able to log in without an org selected
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 15:56 EDT by Chris Duryee
Modified: 2014-09-18 12:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 10:53:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2013-08-08 15:56:12 EDT
Description of problem: users are able to log in without a default org selected. This causes issues with splice-reports and probably other components as well.

Version-Release number of selected component (if applicable): 1.4.3-6


How reproducible: every time


Steps to Reproduce:
1. log in as admin
2. create a new org
3. log out
4. log in again as admin

Actual results: user is able to log in without selecting an org, and gets a blank dashboard (only the "notifications" widget shows"


Expected results: user is forced to select an org when logging in
Comment 1 Marek Hulan 2013-08-15 04:12:37 EDT
This was discussed before. Currently there is no easy way for Signo to ask Katello/SAM for existing organizations for particular user. Signo does not know to which system user is logging in. 

However after user gets into SAM he can set his organization in left upper corner using "Select an Organization" dropdown. This will show dashboard for a particular org. Also when a user have set default org (using star), this org is selected after login automatically. Isn't this sufficient? How about adding notice on "blank" dashboard that use must select organization first?

There is a way to do that in similar way as it is in Katello but with unclean future of Signo I think it's not a good idea to change that (especially since it's not the easy way). An org selection in Signo would mean adding new direction of communication between Signo and RelayParty (Katello in this case). This was meant to be omitted because the plan was to have users and orgs managed by Signo directly.
Comment 2 RHEL Product and Program Management 2013-09-17 00:19:58 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Marek Hulan 2013-10-31 10:53:37 EDT
Signo is going away soon.
Comment 6 Mike McCune 2014-01-16 16:16:59 EST
removing signo component and moving these bugs to 'Infrastructure'

Note You need to log in before you can comment on or make changes to this bug.