Bug 995246 - add note about beaker-proxy needed for beaker-import
add note about beaker-proxy needed for beaker-import
Status: NEW
Product: Beaker
Classification: Community
Component: Doc (Show other bugs)
0.14
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 16:10 EDT by Bill Peck
Modified: 2016-05-26 09:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2013-08-08 16:10:43 EDT
Description of problem:

If beaker-proxy is not running the error reported by beaker-import is not helpful 

Version-Release number of selected component (if applicable):
0.14

How reproducible:
Everytime


It would be nice if the docs at http://beaker-project.org/docs/admin-guide/distro-import.html would mention the need for beaker-proxy running.

Also, beaker-import should report that beaker-proxy is not available or not running if nothing answers on port 8000.
Comment 2 Dan Callaghan 2013-08-21 20:06:43 EDT
We could probably catch some connectivity-related exceptions and re-raise them with a suggestion that beaker-proxy might not be running. Not sure how reliable or worthwhile that would be.

But the docs should definitely make a note of it.

Note You need to log in before you can comment on or make changes to this bug.