Bug 995257 - NPE when both passwords on the installer admin user config page do not match
NPE when both passwords on the installer admin user config page do not match
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER2
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 16:57 EDT by Pavol Srna
Modified: 2014-02-06 10:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:26:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Srna 2013-08-08 16:57:08 EDT
Description of problem: NPE


How reproducible:

* Navigate to Creating A User page in installer
* Fill in passwords that do not match
* Click next (A dialog saying both passwords must match will appear)
* Click ok on the dialog.
* NPE is in the console.


Exception StackTrace:

java.lang.NullPointerException
	at com.redhat.installer.action.PasswordHelper.executeAction(PasswordHelper.java:19)
	at com.izforge.izpack.installer.IzPanel.executePostValidationActions(IzPanel.java:1409)
	at com.izforge.izpack.installer.InstallerFrame.navigateNext(InstallerFrame.java:1651)
	at com.izforge.izpack.installer.InstallerFrame.navigateNext(InstallerFrame.java:1635)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler.navigate(InstallerFrame.java:1798)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler.access$100(InstallerFrame.java:1765)
	at com.izforge.izpack.installer.InstallerFrame$NavigationHandler$1.run(InstallerFrame.java:1782)
	at java.lang.Thread.run(Thread.java:724)
Comment 2 Pavol Srna 2013-08-09 05:55:29 EDT
NPE is thrown on almost all Error/Warning Dialogs.
Comment 3 Thomas Hauser 2013-08-09 10:56:43 EDT
This is due to an izpack bug causing panel actions to run even if validation for the given field has failed. Looking at the code, these NPEs shouldn't be causing any adverse effects on the installation functionality itself. The display of NPEs is fixed in c28adf893a2be7937cd047022ca152ba06228f14.
Comment 4 Jiri Sedlacek 2013-09-17 06:42:48 EDT
verified in ER2

Note You need to log in before you can comment on or make changes to this bug.