Bug 995268 - TypeError: Argument 2 does not allow None as a value - Locale is not being properly set
TypeError: Argument 2 does not allow None as a value - Locale is not being pr...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:1d5640a8e7881666f1c4a452681...
: QA-Closed
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-08-08 18:11 EDT by Shawn Starr
Modified: 2013-08-29 07:25 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 14:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (135.97 KB, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: anaconda.log (2.59 KB, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: environ (441 bytes, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: lsblk_output (1.04 KB, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: os_info (297 bytes, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: program.log (10.87 KB, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: storage.log (23.35 KB, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: syslog (65.37 KB, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: ifcfg.log (486 bytes, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details
File: packaging.log (15.54 KB, text/plain)
2013-08-08 18:12 EDT, Shawn Starr
no flags Details

  None (edit)
Description Shawn Starr 2013-08-08 18:11:59 EDT
Description of problem:
As per the Anaconda developers, there are GTK changes going on in rawhide which currently prevent Anaconda from starting properly. 

Version-Release number of selected component:
anaconda-20.4-1

The following was filed automatically by anaconda:
anaconda 20.4-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 177, in initialize
    itr = store.convert_iter_to_child_iter(itr)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 367, in run
    self._currentAction.initialize()
  File "/sbin/anaconda", line 1073, in <module>
    anaconda._intf.run()
TypeError: Argument 2 does not allow None as a value

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x20rawhide\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc4.git2.1.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide
Comment 1 Shawn Starr 2013-08-08 18:12:04 EDT
Created attachment 784627 [details]
File: anaconda-tb
Comment 2 Shawn Starr 2013-08-08 18:12:07 EDT
Created attachment 784628 [details]
File: anaconda.log
Comment 3 Shawn Starr 2013-08-08 18:12:11 EDT
Created attachment 784629 [details]
File: environ
Comment 4 Shawn Starr 2013-08-08 18:12:14 EDT
Created attachment 784630 [details]
File: lsblk_output
Comment 5 Shawn Starr 2013-08-08 18:12:18 EDT
Created attachment 784631 [details]
File: nmcli_dev_list
Comment 6 Shawn Starr 2013-08-08 18:12:21 EDT
Created attachment 784632 [details]
File: os_info
Comment 7 Shawn Starr 2013-08-08 18:12:25 EDT
Created attachment 784633 [details]
File: program.log
Comment 8 Shawn Starr 2013-08-08 18:12:28 EDT
Created attachment 784634 [details]
File: storage.log
Comment 9 Shawn Starr 2013-08-08 18:12:32 EDT
Created attachment 784635 [details]
File: syslog
Comment 10 Shawn Starr 2013-08-08 18:12:35 EDT
Created attachment 784636 [details]
File: ifcfg.log
Comment 11 Shawn Starr 2013-08-08 18:12:39 EDT
Created attachment 784637 [details]
File: packaging.log
Comment 12 Shawn Starr 2013-08-27 22:40:49 EDT
Used boot.iso with TC1 Fedora 20, fails to start Anaconda graphical installer part.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC1\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
package:        anaconda-20.8-1
product:        Fedora
reason:         TypeError: Argument 2 does not allow None as a value
release:        Cannot get release name.
version:        20-Alpha-TC1

Duplicate of 1000715?
Comment 13 Shawn Starr 2013-08-27 23:54:01 EDT
<handsome_pirate> spstarr:  Check /etc/hostname
<handsome_pirate> spstarr:  There's a bug floating around where it's totally missing
<spstarr> I set dnsmasq dhcp to use DNS from my dns server it got hostname
<spstarr> no failure
<spstarr> handsome_pirate: you are right on
Comment 14 Shawn Starr 2013-08-28 00:20:07 EDT
closed duplicate of 1000715

*** This bug has been marked as a duplicate of bug 1000715 ***
Comment 15 Steve Tyler 2013-08-28 01:04:01 EDT
This avc is in the attached syslog:

22:08:57,983 NOTICE kernel:[   36.876163] type=1400 audit(1375999737.981:17): avc:  denied  { read write } for  pid=684 comm="hostname" path="/dev/pts/1" dev="devpts" ino=4 scontext=system_u:system_r:hostname_t:s0 tcontext=system_u:object_r:devpts_t:s0 tclass=chr_file
Comment 16 Steve Tyler 2013-08-28 01:27:54 EDT
(In reply to Shawn Starr from comment #12)
> Used boot.iso with TC1 Fedora 20, fails to start Anaconda graphical
> installer part.
...

If you can reproduce this, could you attach /tmp/anaconda-tb?
Comment 17 Steve Tyler 2013-08-28 01:33:08 EDT
(In reply to Shawn Starr from comment #12)
> Used boot.iso with TC1 Fedora 20, fails to start Anaconda graphical
> installer part.
> 
> cmdline:        /usr/bin/python  /sbin/anaconda
> cmdline_file:   initrd=initrd.img
> inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC1\x20x86_64 quiet
> BOOT_IMAGE=vmlinuz 
> hashmarkername: anaconda
> kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
> package:        anaconda-20.8-1
> product:        Fedora
> reason:         TypeError: Argument 2 does not allow None as a value
> release:        Cannot get release name.
> version:        20-Alpha-TC1
> 
> Duplicate of 1000715?

Did you copy this from somewhere? It looks like a libreport-generated comment, but the question at the end would not be present.
Comment 18 Kamil Páral 2013-08-28 13:36:51 EDT
Discussed at 2013-08-28 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criteria for non-en-us locales or improperly detected locales: "Release-blocking dedicated installer images must boot to the expected boot menu, and then after a reasonable timeout to the installer." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-08-28/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Expected_image_boot_behavior
Comment 19 Shawn Starr 2013-08-28 13:45:00 EDT
This is geoIP related, locale doesn't appear to be set.

If using ks.cfg setting lang en_US.UTF-8 or en_CA.UTF-8 (in my case) it does not fail and I see the main Installation spoke.

The default locale detection doesn't seem to be setting the locale causing Anaconda to crash on start.
Comment 20 Shawn Starr 2013-08-28 14:20:37 EDT
Close this, there's confusion on MY part, this was GTK+ merge issues before, a new bug will be logged for the locale errors even though libreport shows the same subject line..
Comment 21 Steve Tyler 2013-08-28 14:27:45 EDT
You might need to clear the abrt_hash on this one then, because otherwise dupes will still go to this one ...
Comment 22 Kamil Páral 2013-08-29 05:31:25 EDT
Shawn, if you are really sure this is a different bug from what be debated yesterday (and accepted as a blocker), than please report the correct bug (clear the abrt hash here if necessary) and then transfer the blocker nomination to it. Also mention the new bug here. Thanks.
Comment 23 Kamil Páral 2013-08-29 07:22:55 EDT
Shawn says the new bug is bug 1000715, already accepted as a blocker.
Comment 24 Shawn Starr 2013-08-29 07:25:53 EDT
See the original stack:

Local variables in innermost frame:
info: <gi.FunctionInfo object (convert_iter_to_child_iter) at 0x0x7f76a557e3f0>
args: (<TreeModelFilter object at 0x7f769af94050 (GtkTreeModelFilter at 0x3978960)>, None)
kwargs: {}

This was GTK related even though the subject of the crash was 'TypeError: Argument 2 does not allow None as a value'

The locale issue is:

Local variables in innermost frame:
locale: zu_ZA.UTF-8
self: <pyanaconda.ui.gui.spokes.welcome.WelcomeLanguageSpoke object at 0x7f64c31f8bd0>
locales: ['en_CA.UTF-8', 'fr_CA.UTF-8', 'iu_CA.UTF-8', 'ik_CA.UTF-8', 'shs_CA.UTF-8']
territory: CA
itr: None
store: <TreeModelFilter object at 0x7f64c0920410 (GtkTreeModelFilter at 0x2229a20)>

They aren't exactly the same given the stack trace

Note You need to log in before you can comment on or make changes to this bug.