Bug 99535 - New PCI codes for nv driver
Summary: New PCI codes for nv driver
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: hwdata   
(Show other bugs)
Version: beta1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-21 18:34 UTC by Marc Maurer
Modified: 2014-03-17 02:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 21:02:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v output (4.72 KB, text/plain)
2003-07-25 14:43 UTC, Marc Maurer
no flags Details
lspci -n output (540 bytes, text/plain)
2003-07-25 14:43 UTC, Marc Maurer
no flags Details

Description Marc Maurer 2003-07-21 18:34:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030701
Mozilla Firebird/0.6

Description of problem:
The graphical installer in Severn is unusable due to a totally garbled X display
. My system has a GeForce FX 5200 GO. The text mode works fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start the anaconda graphical installer    

Actual Results:  A totally garbled X

Expected Results:  A normal X display

Additional info:

* acpi=off does not fix the problem.
* RedHat 9 did not have this problem

Comment 1 Marc Maurer 2003-07-21 19:38:32 UTC
The cause of the problems seems to be the card detection:

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
        VendorName  "Videocard vendor"
        BoardName   "VESA driver (generic)"
EndSection

sshing into the box after installation and installing the NVIDIA drivers fixes
the problem.

Comment 2 Jeremy Katz 2003-07-22 14:36:26 UTC
Does it work with the stock nv driver we ship?  Also, lspci information is
helpful in knowing exactly which hardware

Comment 3 Marc Maurer 2003-07-22 15:37:49 UTC
Additional Info:

1. As a correction on my previous post, it seems that the vesa driver is just a
default driver when doing text mode installs. I don't know which driver the
graphical installer tries to use.

2. The nv driver driver has the same problems: a garbled display (I can only
switch to it _after_ the installation, obviously).

3. Furthermore, the NVIDIA drivers works fine until you reboot the box: when
trying to start the graphical bootup screen, the system dies.

4. lspci gives us:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS 645xx (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513 (rev 14)
00:02.3 FireWire (IEEE 1394): Silicon Integrated Systems [SiS] FireWire Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] Intel 537 [56k Winmodem] (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound
Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100
Ethernet (rev 90)
00:06.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan chipset (rev 01)
00:0c.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0324 (rev a1)


Comment 4 Marc Maurer 2003-07-22 16:27:47 UTC
And as a correction upon point #2:

2. The nv driver driver DOES NOT have the same problems. It just needs a power
DOWN, to get it right. I think the 1st boot with the VESA drivers left the
graphics card in some wacko state.



Comment 5 Jeremy Katz 2003-07-24 22:37:55 UTC
Sorry, could you provide lspci -v, and lspci  -n as well?  Then it can be added
to the database to use the nv driver intsead of just falling back to vesa.

Comment 6 Marc Maurer 2003-07-25 14:43:19 UTC
Created attachment 93145 [details]
lspci -v output

Comment 7 Marc Maurer 2003-07-25 14:43:50 UTC
Created attachment 93146 [details]
lspci -n output

Comment 8 Bill Nottingham 2003-08-08 21:02:36 UTC
Added, will be in 0.90-1.


Note You need to log in before you can comment on or make changes to this bug.