Bug 995350 - Failed to start Monitoring of LVM2 mirrors, snapshots etc.
Failed to start Monitoring of LVM2 mirrors, snapshots etc.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Rajnoha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-09 03:27 EDT by Himanshu Garg
Modified: 2014-06-09 09:40 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 09:40:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvmdump (123.96 KB, application/x-compressed-tar)
2013-08-21 09:00 EDT, Himanshu Garg
no flags Details
lvmdump 05 Dec 2013 (124.26 KB, application/gzip)
2013-12-05 08:08 EST, Himanshu Garg
no flags Details

  None (edit)
Description Himanshu Garg 2013-08-09 03:27:10 EDT
Description of problem: 

Sometimes, not always, I get the error message at boot:

lvm2-monitor.service - Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling
   Loaded: loaded (/usr/lib/systemd/system/lvm2-monitor.service; enabled)
   Active: failed (Result: exit-code) since Fri 2013-08-09 12:51:34 IST; 1min 5s ago
     Docs: man:dmeventd(8)
           man:lvcreate(8)
           man:lvchange(8)
           man:vgchange(8)
  Process: 374 ExecStart=/usr/sbin/lvm vgchange --monitor y (code=exited, status=5)

Aug 09 12:51:32 server.example.com lvm[374]: /dev/sr0: open failed: No medium found
Aug 09 12:51:34 server.example.com lvm[374]: 1 logical volume(s) in volume group "fedora" monitored
Aug 09 12:51:34 server.example.com lvm[374]: Volume group "virtual" not found
Aug 09 12:51:34 server.example.com lvm[374]: Volume group "vg_server1" not found
Aug 09 12:51:34 server.example.com systemd[1]: lvm2-monitor.service: main process exited, code=exited,...LLED
Aug 09 12:51:34 server.example.com systemd[1]: Failed to start Monitoring of LVM2 mirrors, snapshots e...ing.
Aug 09 12:51:34 server.example.com systemd[1]: Unit lvm2-monitor.service entered failed state.



Version-Release number of selected component (if applicable):
lvm2-2.02.98-10.fc19.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Himanshu Garg 2013-08-18 00:26:33 EDT
Updated lvm2 Now: lvm2-2.02.98-11.fc19.x86_64

But still the problem persists.
Comment 2 Peter Rajnoha 2013-08-21 04:57:13 EDT
Please, send the output of "lvmdump -u -l" command (a tarball with LVM context and diagnostic info). Thanks.
Comment 3 Himanshu Garg 2013-08-21 09:00:34 EDT
Created attachment 788865 [details]
lvmdump

This is lvmdump tarball.
Comment 4 Himanshu Garg 2013-09-22 00:25:47 EDT
Updated lvm2: lvm2-2.02.98-12.fc19.x86_64

But still the problem persists.
Comment 5 Himanshu Garg 2013-12-05 07:37:44 EST
Updated: lvm2-2.02.98-13.fc19.x86_64

But problem still persists.
Comment 6 Himanshu Garg 2013-12-05 08:08:37 EST
Created attachment 833144 [details]
lvmdump 05 Dec 2013
Comment 7 Peter Rajnoha 2014-04-09 07:16:20 EDT
Is this still reproducible with latest lvm2 package? (lvm2-2.02.98-15.fc19)
Or even in Fedora 20 (if you already upgraded in the meantime)?

If yes, could you please edit /lib/systemd/system/lvm2-monitor.service and add -vvvv option (verbose log) to the vgchange --monitor y command on the ExecStart line like this:

   ExecStart=/usr/sbin/lvm vgchange --monitor y -vvvv

The reboot the machine and paste the log here please:

   systemctl status -l -n 100000 lvm2-monitor.service

Thanks.
Comment 8 Himanshu Garg 2014-06-09 09:33:33 EDT
Problem is not there in Fedora 20 with lvm2-2.02.103-3.fc20.x86_64

Thanks.
Comment 9 Peter Rajnoha 2014-06-09 09:40:35 EDT
OK, I'm marking closed/nextrelease then. If the problem appears again, feel free to reopen this report.

Note You need to log in before you can comment on or make changes to this bug.